Permalink
Browse files

Bump dependancy on `template-haskell` to allow version 2.8

...and add top-level signature for `errmsg` to silence compiler warning
  • Loading branch information...
1 parent 2132129 commit ebdb380d1f39382605e85294529ba083211b4678 @hvr hvr committed Sep 8, 2012
Showing with 2 additions and 1 deletion.
  1. +1 −0 Data/Lens/Template.hs
  2. +1 −1 data-lens-template.cabal
View
@@ -134,6 +134,7 @@ decMakeLens t dec namer = do
#endif
+errmsg :: Show a => a -> [Char]
errmsg t = "Cannot derive accessors for name " ++ show t ++ " because"
++ "\n it is not a type declared with 'data' or 'newtype'"
++ "\n Did you remember to double-tick the type as in"
View
@@ -22,7 +22,7 @@ library
build-depends:
data-lens >= 2.0 && < 2.11,
base >= 1.0 && < 5,
- template-haskell >= 2.4 && < 2.8
+ template-haskell >= 2.4 && < 2.9
exposed-modules:
Data.Lens.Template

0 comments on commit ebdb380

Please sign in to comment.