Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

conditionalized nats dependency

  • Loading branch information...
commit 8d715fcef482044ebcdfbd5848bfc858a0e38ef3 1 parent f4d40e8
@ekmett authored
Showing with 14 additions and 2 deletions.
  1. +4 −0 CHANGELOG.markdown
  2. +10 −2 lens.cabal
View
4 CHANGELOG.markdown
@@ -1,3 +1,7 @@
+3.8.0.1
+-------
+* Fixed an issue with running the `doctests` test suite when an older version of `semigroups` is installed.
+
3.8
---
* Overall:
View
12 lens.cabal
@@ -1,6 +1,6 @@
name: lens
category: Data, Lenses
-version: 3.8
+version: 3.8.0.1
license: BSD3
cabal-version: >= 1.8
license-file: LICENSE
@@ -158,6 +158,10 @@ flag lib-Werror
default: False
manual: True
+flag old-semigroups
+ default: False
+ manual: False
+
library
build-depends:
array >= 0.3.0.2 && < 0.5,
@@ -361,13 +365,17 @@ test-suite doctests
doctest >= 0.9.1,
filepath,
mtl,
- nats,
parallel,
simple-reflect >= 0.3.1,
split,
text,
unordered-containers,
vector
+
+ if !flag(old-semigroups)
+ build-depends: semigroups >= 0.8.4 && < 0.9
+ else
+ build-depends: semigroups >= 0.9, nats
ghc-options: -Wall -threaded
if impl(ghc<7.6.1)
ghc-options: -Werror
Please sign in to comment.
Something went wrong with that request. Please try again.