Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Package can't be installed with transformers-0.2.2.0 and GHC 7.2.2 #10

Closed
bjpe opened this Issue · 2 comments

2 participants

@bjpe

Trying to install semigroupoids using transformers-0.2.2.0 and GHC 7.2.2 I get the following error message:

Configuring semigroupoids-3.1...
Building semigroupoids-3.1...
Preprocessing library semigroupoids-3.1...
[ 1 of 12] Compiling Data.Traversable.Instances ( src/Data/Traversable/Instances.hs, dist/build/Data/Traversable/Instances.o )
[ 2 of 12] Compiling Data.Functor.Extend ( src/Data/Functor/Extend.hs, dist/build/Data/Functor/Extend.o )

src/Data/Functor/Extend.hs:24:1:
    transformers-0.2.2.0:Control.Monad.Trans.Identity can't be safely imported! The module itself isn't safe.
Failed to install semigroupoids-3.1

It seems to be the same issue like ekmett/contravariant#4 .

@ekmett
Owner

We should at least mark the versions so it doesn't try to build there.

@ekmett
Owner

This is resolved in HEAD. We'll no longer try to build on GHC < 7.6.

@ekmett ekmett closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.