semigroups-0.8 as on hackage doesn't compile against base-4.5.0.0 (from ghc-7.4.1) #1

Closed
MedeaMelana opened this Issue Feb 19, 2012 · 3 comments

Projects

None yet

2 participants

Hi Edward,

A fresh cabal install semigroups fails with:

Data/Semigroup.hs:54:10:
    Ambiguous occurrence `<>'
    It could refer to either `Data.Semigroup.<>',
                             defined at Data/Semigroup.hs:57:3
                          or `Monoid.<>',
                             imported from `Data.Monoid' at Data/Semigroup.hs:35:1-47

But cloning the repository and building from there works fine. Could you upload an updated version to Hackage please?

Thanks,

Martijn.

Never mind, I was trying to install an old version of semigroups. My bad!

Owner
ekmett commented Feb 19, 2012

I must have missed the upload when I was fixing the others. I'll push it when I get home tonight.

Sent from my iPhone

On Feb 19, 2012, at 3:18 PM, Martijn van Steenbergenreply@reply.github.com wrote:

Hi Edward,

A fresh cabal install semigroups fails with:

Data/Semigroup.hs:54:10:
   Ambiguous occurrence `<>'
   It could refer to either `Data.Semigroup.<>',
                            defined at Data/Semigroup.hs:57:3
                         or `Monoid.<>',
                            imported from `Data.Monoid' at Data/Semigroup.hs:35:1-47

But cloning the repository and building from there works fine. Could you upload an updated version to Hackage please?

Thanks,

Martijn.


Reply to this email directly or view it on GitHub:
#1

I lied; I wasn't doing a cabal install semigroups; rather I was installing one of my own packages which depended on an old version of semigroups. -hangs head in shame-

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment