Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pi-Hole Exporter Dashboard Doesn't Show Any Data By Default #3

Closed
GregHilston opened this issue May 17, 2019 · 6 comments

Comments

Projects
None yet
3 participants
@GregHilston
Copy link

commented May 17, 2019

I am unable to get the PI-Hole Exporter Dashboard to display any data when using this project. I realize that the dashboard mentioned is not this project specifically, but perhaps you would know how to resolve this issue, as you also wrote the dashboard haha.

I've tried importing the dashboard by id (10176) and also by using its JSON and still have not been successful.

My setup may differ from yours, as my Grafana and Prometheus installs are dockerized on some machine A and my pihole exporter is on some machine B. I've attempted to configure the JSON to point at the machine B, where the pihole exporter is running and have been successful at getting my own graphs to display, but not the ones in your dashboard.

Any thoughts or advice would be greatly appreciated, as your dashboard looks lovely.

@GregHilston

This comment has been minimized.

Copy link
Author

commented May 20, 2019

@eko Any thoughts on this? If you have any idea, I'd be happy to go explore down that path

@eko

This comment has been minimized.

Copy link
Owner

commented May 24, 2019

Hi @GregHilston,

Sorry for the late answer.

Sorry but I've just tried to understand what's happening and I have no idea. Is your Prometheus server configured as a data source on your Grafana settings?

What you can also try is:

After importing the dashboard, go to dashboard settings and ensure you selected the right source here:

Capture d’écran 2019-05-24 à 08 51 18

@kendellmendoza

This comment has been minimized.

Copy link

commented May 26, 2019

Hi, same issue here. It seems that the problem is due to the dashboard attempting to use the user's Default data source as opposed to using Prometheus. My Default was InfluxDB, but after changing it to Prometheus, all panels now display correctly.

image

@GregHilston

This comment has been minimized.

Copy link
Author

commented May 29, 2019

Apologies for the late reply.

@kendellmendoza @eko I'm going to try to provide as much information as possible, hopefully one of you will see the issue jump out at you.

My UI looks strangely different from both of yours:

image

Here is my data source, running on the same device but a different container
image

output of $ docker ps
image

Proof I have data in prometheus:

image

I've attached my dashboard's config, as a json file (its labeled as a txt file, as github wouldn't let be attach a json file....

pihole_dashboard_config.txt

If this is something simple, please forgive me. This is my first grafana/prometheus project

@eko

This comment has been minimized.

Copy link
Owner

commented May 29, 2019

Hi @GregHilston,

It appears you are running Grafana v4.1.2 while we are running on v6.x versions. You could upgrade to this new version (only Grafana, which displays data) in order to have the same screens.

Moreover, Grafana has changed its Dashboard layout template since v5 (see: https://grafana.com/docs/guides/whats-new-in-v5/#new-dashboard-layout-engine) so I can’t ensure the dashboard will work on older versions.

Thank you

@eko

This comment has been minimized.

Copy link
Owner

commented Jun 6, 2019

Closing this issue as the dashboard is working on recent Grafana versions.

Thank you

@eko eko closed this Jun 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.