Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
193 lines (192 sloc) 10.2 KB
digraph "maven2" {
rankdir=LR;
node [shape=box];
"maven2" -> "debhelper" [color=darkgoldenrod,style=bold,label="(>= 6)"];
"maven2" -> "cdbs" [color=darkgoldenrod,style=bold,label="(>= 0.4.5.3)"];
"cdbs" -> "debhelper" [color=blue,label="(>= 5.0.30)"];
"cdbs" -> "fdupes" [color=blue];
"cdbs" -> "intltool" [color=blue];
"intltool" -> "gettext" [color=blue,label="(>= 0.10.36-1)"];
"intltool" -> "patch" [color=blue];
"intltool" -> "automake" [color=blue];
"automake" -> "autoconf" [color=blue,label="(>= 2.62)"];
"autoconf" -> "perl" [color=blue,label="(>> 5.005)"];
"autoconf" -> "m4" [color=blue,label="(>= 1.4.13)"];
"m4" -> "dpkg" [color=blue,label="(>= 1.15.4)"];
"autoconf" -> "debianutils" [color=blue,label="(>= 1.8)"];
"debianutils" -> "sensible-utils" [color=blue];
"automake" -> "autotools-dev" [color=blue,label="(>= 20020320.1)"];
"automake" -> "dpkg" [color=blue,label="(>= 1.15.4)"];
"intltool" -> "perl" [color=blue];
"intltool" -> "libxml-parser-perl" [color=blue];
"libxml-parser-perl" -> "perl" [color=blue,label="(>= 5.10.1-8ubuntu1)"];
"libxml-parser-perl" -> "perlapi-5.10.1" [color=blue];
"perlapi-5.10.1" -> "perl-base" [dir=back,arrowtail=inv,color=green];
"perl-base" -> "dpkg" [color=purple,style=bold,label="(>= 1.14.20)"];
"perlapi-5.10.1" [shape=octagon];
"libxml-parser-perl" -> "liburi-perl" [color=blue];
"liburi-perl" -> "perl" [color=blue];
"liburi-perl" -> "libmime-base64-perl" [color=blue];
"libmime-base64-perl" -> "perl" [dir=back,arrowtail=inv,color=green];
"libmime-base64-perl" [shape=octagon];
"liburi-perl" -> "libnet-perl" [color=blue];
"libnet-perl" -> "perl-modules" [dir=back,arrowtail=inv,color=green];
"perl-modules" -> "perl" [color=blue,label="(>= 5.10.1-1)"];
"libnet-perl" [shape=octagon];
"libxml-parser-perl" -> "libwww-perl" [color=blue];
"libwww-perl" -> "perl" [color=blue];
"libwww-perl" -> "liburi-perl" [color=blue];
"libwww-perl" -> "libhtml-parser-perl" [color=blue];
"libhtml-parser-perl" -> "perl" [color=blue,label="(>= 5.10.0-24ubuntu4)"];
"libhtml-parser-perl" -> "perlapi-5.10.0" [color=blue];
"perlapi-5.10.0" -> "perl-base" [dir=back,arrowtail=inv,color=green];
"perlapi-5.10.0" [shape=octagon];
"libhtml-parser-perl" -> "liburi-perl" [color=blue];
"libhtml-parser-perl" -> "libhtml-tagset-perl" [color=blue];
"libhtml-tagset-perl" -> "perl" [color=blue,label="(>= 5.6.0-16)"];
"libwww-perl" -> "libhtml-tree-perl" [color=blue];
"libhtml-tree-perl" -> "perl" [color=blue,label="(>= 5.6.0-16)"];
"libhtml-tree-perl" -> "libhtml-parser-perl" [color=blue];
"libhtml-tree-perl" -> "libhtml-tagset-perl" [color=blue,label="(>= 3.02)"];
"libwww-perl" -> "libhtml-tagset-perl" [color=blue];
"libwww-perl" -> "netbase" [color=blue];
"netbase" -> "lsb-base" [color=blue,label="(>= 3.0-6)"];
"lsb-base" -> "sed" [color=blue];
"sed" -> "dpkg" [color=blue,label="(>= 1.15.4)"];
"sed" -> "libselinux1" [color=purple,style=bold,label="(>= 1.32)"];
"lsb-base" -> "ncurses-bin" [color=blue];
"ncurses-bin" -> "libncurses5" [color=purple,style=bold,label="(>= 5.6+20071006-3)"];
"netbase" -> "upstart-job" [color=blue];
"upstart-job" -> "upstart" [dir=back,arrowtail=inv,color=green];
"upstart" -> "libdbus-1-3" [color=blue,label="(>= 1.2.16)"];
"upstart" -> "libnih-dbus1" [color=blue,label="(>= 1.0.0)"];
"libnih-dbus1" -> "libnih1" [color=blue,label="(= 1.0.1-1)"];
"libnih-dbus1" -> "libdbus-1-3" [color=blue,label="(>= 1.2.16)"];
"upstart" -> "libnih1" [color=blue,label="(>= 1.0.0)"];
"upstart" -> "libudev0" [color=blue,label="(>= 151-5)"];
"upstart" -> "sysvinit-utils" [color=blue];
"sysvinit-utils" -> "libselinux1" [color=blue,label="(>= 1.32)"];
"sysvinit-utils" -> "libsepol1" [color=blue,label="(>= 1.14)"];
"upstart" -> "sysv-rc" [color=blue];
"sysv-rc" -> "debconf" [color=blue];
"sysv-rc" -> "sysvinit-utils" [color=blue,label="(>= 2.86.ds1-62)"];
"sysv-rc" -> "insserv" [color=blue,label="(>> 1.12.0-10)"];
"upstart" -> "initscripts" [color=blue];
"initscripts" -> "mount" [color=blue,label="(>= 2.11x-1)"];
"mount" -> "libblkid1" [color=purple,style=bold,label="(>= 2.17)"];
"libblkid1" -> "libuuid1" [color=blue,label="(>= 2.16)"];
"libuuid1" -> "passwd" [color=blue];
"mount" -> "libselinux1" [color=purple,style=bold,label="(>= 2.0.15)"];
"mount" -> "libsepol1" [color=purple,style=bold,label="(>= 1.14)"];
"mount" -> "libuuid1" [color=purple,style=bold,label="(>= 2.16)"];
"initscripts" -> "debianutils" [color=blue,label="(>= 2.13.1)"];
"initscripts" -> "lsb-base" [color=blue,label="(>= 3.2-14)"];
"initscripts" -> "sysvinit-utils" [color=blue,label="(>= 2.86.ds1-39)"];
"initscripts" -> "sysv-rc" [color=blue];
"initscripts" -> "passwd" [color=blue];
"initscripts" -> "upstart" [color=blue];
"upstart" -> "mountall" [color=blue];
"mountall" -> "makedev" [color=blue];
"makedev" -> "base-passwd" [color=blue,label="(>= 3.0.4)"];
"mountall" -> "udev" [color=blue];
"udev" -> "libacl1" [color=blue,label="(>= 2.2.11-1)"];
"libacl1" -> "libattr1" [color=blue,label="(>= 2.4.41-1)"];
"udev" -> "libglib2.0-0" [color=blue,label="(>= 2.16.0)"];
"udev" -> "libselinux1" [color=blue,label="(>= 1.32)"];
"udev" -> "libusb-0.1-4" [color=blue,label="(>= 2:0.1.12)"];
"udev" -> "upstart-job" [color=blue];
"udev" -> "module-init-tools" [color=blue,label="(>= 3.2.1-0ubuntu3)"];
"module-init-tools" -> "upstart-job" [color=blue];
"udev" -> "initramfs-tools" [color=blue,label="(>= 0.92bubuntu63)"];
"initramfs-tools" -> "initramfs-tools-bin" [color=blue,label="(= 0.92bubuntu78)"];
"initramfs-tools-bin" -> "libudev0" [color=blue,label="(>= 147)"];
"initramfs-tools" -> "klibc-utils" [color=blue,label="(>= 1.5.9-1)"];
"klibc-utils" -> "libklibc" [color=blue,label="(= 1.5.17-4ubuntu1)"];
"initramfs-tools" -> "busybox-initramfs" [color=blue,label="(>= 1:1.13.3-1ubuntu5)"];
"initramfs-tools" -> "cpio" [color=blue];
"initramfs-tools" -> "module-init-tools" [color=blue];
"initramfs-tools" -> "udev" [color=blue,label="(>= 147~-5)"];
"initramfs-tools" -> "findutils" [color=blue,label="(>= 4.2.24)"];
"initramfs-tools" -> "util-linux" [color=blue,label="(>> 2.15~rc1)"];
"util-linux" -> "upstart-job" [color=blue];
"util-linux" -> "lsb-base" [color=blue,label="(>= 3.0-6)"];
"util-linux" -> "tzdata" [color=blue,label="(>= 2006c-2)"];
"tzdata" -> "debconf" [color=blue,label="(>= 0.5)"];
"util-linux" -> "dpkg" [color=blue,label="(>= 1.15.4)"];
"util-linux" -> "libblkid1" [color=purple,style=bold,label="(>= 2.17)"];
"util-linux" -> "libncurses5" [color=purple,style=bold,label="(>= 5.6+20071006-3)"];
"util-linux" -> "libselinux1" [color=purple,style=bold,label="(>= 1.32)"];
"util-linux" -> "libslang2" [color=purple,style=bold,label="(>= 2.0.7-1)"];
"util-linux" -> "libuuid1" [color=purple,style=bold,label="(>= 2.16)"];
"udev" -> "procps" [color=blue];
"procps" -> "libncurses5" [color=blue,label="(>= 5.6+20071006-3)"];
"procps" -> "upstart-job" [color=blue];
"procps" -> "lsb-base" [color=blue,label="(>= 3.0-10)"];
"udev" -> "adduser" [color=blue];
"adduser" -> "perl-base" [color=blue,label="(>= 5.6.0)"];
"adduser" -> "passwd" [color=blue,label="(>= 1:4.0.12)"];
"adduser" -> "debconf" [color=blue];
"udev" -> "util-linux" [color=blue,label="(>> 2.15~rc2)"];
"mountall" -> "plymouth" [color=blue];
"plymouth" -> "libdrm-intel1" [color=blue,label="(>= 2.4.9)"];
"libdrm-intel1" -> "libdrm2" [color=blue,label="(>= 2.4.1)"];
"plymouth" -> "libdrm-nouveau1" [color=blue,label="(>= 2.4.11-1ubuntu1~)"];
"libdrm-nouveau1" -> "libdrm2" [color=blue,label="(>= 2.4.3)"];
"plymouth" -> "libdrm-radeon1" [color=blue,label="(>= 2.4.17)"];
"libdrm-radeon1" -> "libdrm2" [color=blue,label="(>= 2.4.3)"];
"plymouth" -> "libdrm2" [color=blue,label="(>= 2.4.3)"];
"plymouth" -> "libplymouth2" [color=blue,label="(= 0.8.2-2ubuntu2)"];
"libplymouth2" -> "libpng12-0" [color=blue,label="(>= 1.2.13-4)"];
"plymouth" -> "upstart-job" [color=blue];
"plymouth" -> "udev" [color=blue,label="(>= 149-2)"];
"plymouth" -> "mountall" [color=blue,label="(>= 2.0)"];
"plymouth" -> "initramfs-tools" [color=blue];
"mountall" -> "coreutils" [color=blue,label="(>= 7.1)"];
"coreutils" -> "libacl1" [color=purple,style=bold,label="(>= 2.2.11-1)"];
"coreutils" -> "libattr1" [color=purple,style=bold,label="(>= 2.4.41-1)"];
"coreutils" -> "libselinux1" [color=purple,style=bold,label="(>= 1.32)"];
"mountall" -> "libdbus-1-3" [color=blue,label="(>= 1.2.16)"];
"mountall" -> "libnih-dbus1" [color=blue,label="(>= 1.0.0)"];
"mountall" -> "libnih1" [color=blue,label="(>= 1.0.0)"];
"mountall" -> "libplymouth2" [color=blue,label="(>= 0.8.1-3)"];
"mountall" -> "libudev0" [color=blue,label="(>= 151-5)"];
"upstart" -> "ifupdown" [color=blue,label="(>= 0.6.8ubuntu29)"];
"ifupdown" -> "net-tools" [color=blue];
"ifupdown" -> "debconf" [color=blue,label="(>= 1.2.0)"];
"ifupdown" -> "upstart-job" [color=blue];
"ifupdown" -> "lsb-base" [color=blue,label="(>= 1.3-9ubuntu3)"];
"ifupdown" -> "netbase" [color=blue,label="(>= 4.30ubuntu2)"];
"upstart-job" [shape=octagon];
"libxml-parser-perl" -> "libexpat1" [color=blue,label="(>= 1.95.8)"];
"intltool" -> "file" [color=blue];
"file" -> "libmagic1" [color=blue,label="(= 5.03-5ubuntu1)"];
"maven2" -> "default-jdk" [color=darkgoldenrod,style=bold];
"default-jdk" -> "default-jre" [color=blue,label="(= 1.6-34)"];
"default-jdk" -> "openjdk-6-jdk" [color=blue,label="(>= 6b14)"];
"openjdk-6-jdk" -> "openjdk-6-jre" [color=blue,label="(>= 6b18-1.8.1-0ubuntu1)"];
"maven2" -> "ant" [color=darkgoldenrod,style=bold];
"ant" -> "default-jre-headless" [color=blue];
"ant" -> "libxerces2-java" [color=blue];
"libxerces2-java" -> "default-jre-headless" [color=blue];
"libxerces2-java" -> "libjaxp1.3-java" [color=blue];
"libjaxp1.3-java" -> "default-jre-headless" [color=blue];
"maven2" -> "quilt" [color=darkgoldenrod,style=bold];
"quilt" -> "patch" [color=blue];
"quilt" -> "diffstat" [color=blue];
"quilt" -> "bzip2" [color=blue];
"bzip2" -> "libbz2-1.0" [color=blue,label="(= 1.0.5-4)"];
"quilt" -> "gettext" [color=blue];
"maven2" [style="setlinewidth(2)"]
"debconf" [shape=diamond];
"debhelper" [shape=diamond];
"default-jre" [shape=diamond];
"default-jre-headless" [shape=diamond];
"dpkg" [shape=diamond];
"gettext" [shape=diamond];
"libglib2.0-0" [shape=diamond];
"openjdk-6-jre" [shape=diamond];
"passwd" [shape=diamond];
"perl" [shape=diamond];
}
// Excluded dependencies:
// libc6 libx11-6 zlib1g