Skip to content
31 lines (27 sloc) 1.21 KB
# -*- encoding: utf-8 -*-
lib = File.expand_path("../lib", __FILE__)
$LOAD_PATH.unshift(lib) unless $LOAD_PATH.include?(lib)
require "pundit/version"
Gem::Specification.new do |gem|
gem.name = "pundit"
gem.version = Pundit::VERSION
gem.authors = ["Jonas Nicklas", "Elabs AB"]
gem.email = ["jonas.nicklas@gmail.com", "dev@elabs.se"]
gem.description = "Object oriented authorization for Rails applications"
gem.summary = "OO authorization for Rails"
gem.homepage = "https://github.com/elabs/pundit"
gem.license = "MIT"
gem.files = `git ls-files`.split($/)
gem.executables = gem.files.grep(%r{^bin/}).map { |f| File.basename(f) }
gem.test_files = gem.files.grep(%r{^(test|spec|features)/})
gem.require_paths = ["lib"]
gem.add_dependency "activesupport", ">= 3.0.0"
gem.add_development_dependency "activemodel", ">= 3.0.0"
gem.add_development_dependency "actionpack", ">= 3.0.0"
gem.add_development_dependency "bundler", "~> 1.3"
gem.add_development_dependency "rspec", ">=2.0.0"
gem.add_development_dependency "pry"
gem.add_development_dependency "rake"
gem.add_development_dependency "yard"
gem.add_development_dependency "rubocop"
end
Jump to Line
Something went wrong with that request. Please try again.