Failed to install cloud-aws, reason: failed to download v0.19.0 #1792

Closed
jspooner opened this Issue Mar 18, 2012 · 4 comments

Comments

Projects
None yet
4 participants

Following the install instructions and it looks like version 19 is unable to install cloud-aws because of an incorrect url.

wget https://github.com/downloads/elasticsearch/elasticsearch/elasticsearch-0.19.0.zip
...snip...
[ec2-user@x elasticsearch]$ cd elasticsearch-0.19.0/
[ec2-user@x elasticsearch-0.19.0]$ sudo bin/plugin -install cloud-aws
-> Installing cloud-aws...
Trying http://elasticsearch.googlecode.com/svn/plugins/cloud-aws/elasticsearch-cloud-aws-0.19.0.zip...
Failed to install cloud-aws, reason: failed to download

I was able to install cloud-aws by using v0.18.7.

Thanks

Owner

kimchy commented Mar 18, 2012

In 0.19, all the plugins have moved to their own github repo, and the installation is different, see more on the readme here: https://github.com/elasticsearch/elasticsearch-cloud-aws.

Thanks I was able to install v19 with cloud-aws with that.
https://github.com/elasticsearch/elasticsearch.github.com/pull/162

Might want to update/change the public docs for this:

http://www.elasticsearch.org/guide/reference/modules/discovery/ec2/

bin/plugin -install cloud-aws does not work for me, but bin/plugin -install elasticsearch/elasticsearch-cloud-aws/1.12.0 did

@ghost ghost assigned spinscale Jun 8, 2013

Member

spinscale commented Aug 9, 2013

The official documentation now references to the plugin website, see https://github.com/elasticsearch/elasticsearch.github.com/commit/f49db322dd7c23dbc8183479281b4fbb05e64ba6

@spinscale spinscale closed this Aug 9, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment