Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Analyzer added via Update Settings (on temporarily closed index) not found by Put Mapping #2225

Closed
kennknowles opened this issue Aug 31, 2012 · 1 comment

Comments

@kennknowles
Copy link
Contributor

@kennknowles kennknowles commented Aug 31, 2012

Hello, I am using version 0.19.8 but I do not see a mention of this in the 0.19.9 release notes so I presume it remains true.

I have two gists which I believe are intended to be equivalent, but they are not:

The failure is {"error":"MapperParsingException[Analyzer [my_analyzer] not found for field [custom_field]]","status":400}

By the way, the only place I found documented that _close and _open are necessary is http://elasticsearch-users.115913.n3.nabble.com/Adding-analyzers-during-runtime-td3412592.html

@kimchy

This comment has been minimized.

Copy link
Member

@kimchy kimchy commented Sep 2, 2012

The problem is that the format of the update settings API body is not correct, it includes the settings top level element, where it shouldn't. Once you remove it, things will work.

To be honest, I agree its confusing, I will open an issue to support also top level settings element: #2227.

@kimchy kimchy closed this Sep 2, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.