Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Debian package dependencies can result in java uninstallation #3284

Closed
spinscale opened this Issue Jul 3, 2013 · 1 comment

Comments

Projects
None yet
1 participant
@spinscale
Copy link
Member

spinscale commented Jul 3, 2013

The discussion happened at #3105

The Java dependency was changed from "Depends" to "Suggest" - which sounded good, but could result in uninstallation of java, in case no other package depended on java.

Maybe the 'Enhances' flag can help here, need to investigate, see #3105 (comment)

@ghost ghost assigned spinscale Jul 3, 2013

@spinscale

This comment has been minimized.

Copy link
Member Author

spinscale commented Jul 15, 2013

Closed by c59b0b2

We decided, that it is still allowed to have elasticsearch packages installed anywhere without a java installation, but the init script now returns a clear error. Also all suggests/depends in debian package were removed. For more information see the commit comment

@spinscale spinscale closed this Jul 15, 2013

martijnvg added a commit that referenced this issue Apr 25, 2018

Merge remote-tracking branch 'es/6.x' into ccr-6.x
* es/6.x: (106 commits)
  Revert "Fix elasticsearch-cli dependency"
  Fix elasticsearch-cli dependency
  [Watcher] Use index.auto_expand_replicas: 0-1 (#3284)
  [DOCS] Reformatted machine learning overview (#3346)
  [DOCS] Added monitoring PRs to 6.1 release notes (#3297)
  [DOCS] Added xpack.ml.node_concurrent_job_allocations setting (#3327)
  [DOCS] Fixed troubleshooting titles
  Watcher: Set index and type dynamically in index action (#3264)
  Tests: Ensure that watcher is started in HipchatServiceTests
  Fix test due to BytesSizeValue negative value deprecation
  [DOCS] Explain ML datafeed run-as integration/limitations (#3311)
  Monitoring: Ensure all monitoring watches filter by timestamp (#3238)
  Fix license messaging for Logstash functionality (#3268)
  [DOCS] Updated titles of ML APIs
  Fixes test to support BytesSizeValue changes (#3321)
  Revert "Fixes test to support BytesSizeValue changes (#3321)"
  Fixes test to support BytesSizeValue changes (#3321)
  Add missing import
  Check for existing x-pack directory when running the `users` CLI tool (#3271)
  [DOCS] Fixed title in 6.1.0 release notes
  ...
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.