New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

TribeNode throws NPE if index doesn't exist #5643

Closed
s1monw opened this Issue Apr 1, 2014 · 0 comments

Comments

Projects
None yet
1 participant
@s1monw
Contributor

s1monw commented Apr 1, 2014

[2014-04-01 08:00:24,976][WARN ][tribe                    ] [Keith Kilham] failed to process [cluster event from t2, local-disco-receive(from master)]
java.lang.NullPointerException
    at org.elasticsearch.tribe.TribeService$TribeClusterStateListener$1.execute(TribeService.java:315)
    at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:309)
    at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:134)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
    at java.lang.Thread.run(Thread.java:724)

@s1monw s1monw added bug labels Apr 1, 2014

@s1monw s1monw self-assigned this Apr 1, 2014

@s1monw s1monw removed the v1.1.1 label Apr 1, 2014

@s1monw s1monw closed this in 4da66c4 Apr 1, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment