Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump lodash for use with Kibana 6.8 #2280

Closed
tylersmalley opened this issue Sep 4, 2019 · 2 comments

Comments

@tylersmalley
Copy link
Member

commented Sep 4, 2019

In elastic/kibana#41033 @kobelb bumped Lodash for 6.8, however, we are now seeing an error thrown when installing dependencies:

warning Pattern ["lodash@npm:@elastic/lodash@3.10.1-kibana3","lodash@npm:@elastic/lodash@3.10.1-kibana1"] is trying to unpack in the same destination "/home/tyler/.cache/yarn/v4/npm-lodash-3.10.1-kibana3-c0e318245219eeeff535895c429e0cef5058a9ad/node_modules/lodash" as pattern ["lodash@npm:@elastic/lodash@3.10.1-kibana3"]. This could result in non-deterministic behavior, skipping.

This is due to the EUI (6.10.8) requiring @elastic/lodash@3.10.1-kibana1. We need to also bump this to npm:@elastic/lodash@3.10.1-kibana3. If possible, we only want to make this change and release 6.10.9 for which we can bump in Kibana 6.8.

@chandlerprall chandlerprall self-assigned this Sep 5, 2019

@chandlerprall chandlerprall referenced this issue Sep 5, 2019
1 of 1 task complete
@chandlerprall

This comment has been minimized.

Copy link
Contributor

commented Sep 5, 2019

I've released eui@6.10.9 with the requested change, PR updating Kibana is elastic/kibana#44921

@chandlerprall

This comment has been minimized.

Copy link
Contributor

commented Sep 5, 2019

Merged.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.