Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Idios missing forms module? #3

Open
rca opened this Issue · 0 comments

1 participant

@rca
rca commented

While trying to run pinax tests using:

python tests/runner.py

I get the following traceback mentioning idios.forms is not found:

(pinax-env) berto@bolt$ python tests/runner.py 2>&1 | sed 's/^/    /'
Traceback (most recent call last):
  File "tests/runner.py", line 161, in <module>
    main()
  File "tests/runner.py", line 153, in main
    call_command("test", verbosity=int(options.verbosity), *args)
  File "/Users/berto/local/opt/django/1.2.4/django/core/management/__init__.py", line 166, in call_command
    return klass.execute(*args, **defaults)
  File "/Users/berto/local/opt/django/1.2.4/django/core/management/base.py", line 220, in execute
    output = self.handle(*args, **options)
  File "/Users/berto/local/opt/django/1.2.4/django/core/management/commands/test.py", line 37, in handle
    failures = test_runner.run_tests(test_labels)
  File "/Users/berto/local/opt/django/1.2.4/django/test/simple.py", line 396, in run_tests
    suite = self.build_suite(test_labels, extra_tests)
  File "/Users/berto/local/opt/django/1.2.4/django/test/simple.py", line 289, in build_suite
    suite.addTest(build_suite(app))
  File "/Users/berto/local/opt/django/1.2.4/django/test/simple.py", line 116, in build_suite
    test_module = get_tests(app_module)
  File "/Users/berto/local/opt/django/1.2.4/django/test/simple.py", line 74, in get_tests
    test_module = __import__('.'.join(app_path + [TEST_MODULE]), {}, {}, TEST_MODULE)
  File "/Users/berto/Places/home/Projects/pinax-env/lib/python2.6/site-packages/idios/tests/__init__.py", line 1, in <module>
    from test_form import *
  File "/Users/berto/Places/home/Projects/pinax-env/lib/python2.6/site-packages/idios/tests/test_form.py", line 7, in <module>
    from idios.forms import ProfileForm
ImportError: No module named forms

The idios package was installed running:

pip install idios==0.1.dev6

Taking a quick peek at the idios repo, I don't see a forms module.

Any ideas? Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.