Skip to content
Permalink
Browse files

chore: upgrade tslint-config-airbnb

  • Loading branch information
malept committed Sep 1, 2018
1 parent 4a1c449 commit 3618e99184c59fbb4b14ad9716ec5e72c9dee2e4
@@ -147,7 +147,7 @@
"sinon": "^4.1.2",
"ts-node": "^6.0.0",
"tslint": "^5.9.1",
"tslint-config-airbnb": "^5.8.0",
"tslint-config-airbnb": "^5.11.0",
"typedoc": "^0.11.1",
"typescript": "^2.8.1"
},
@@ -43,8 +43,8 @@ program
});

if (!goodSystem) {
console.error(('It looks like you are missing some dependencies you need to get Electron running.\n' +
'Make sure you have git installed and Node.js version 6.0.0+').red);
console.error((`It looks like you are missing some dependencies you need to get Electron running.
Make sure you have git installed and Node.js version 6.0.0+`).red);
process.exit(1);
}

@@ -49,10 +49,8 @@ function warnIfPackageManagerIsntAKnownGoodVersion(packageManager: string, versi
const versions = osVersions ? `${whitelistedVersions.all} || ${osVersions}` : whitelistedVersions.all;
const versionString = version.toString();
if (!validPackageManagerVersion(packageManager, versionString, versions, ora)) {
ora.warn!(
`You are using ${packageManager}, but not a known good version.\n` +
`The known versions that work with Electron Forge are: ${versions}`,
);
ora.warn!(`You are using ${packageManager}, but not a known good version.
The known versions that work with Electron Forge are: ${versions}`);
}
}

@@ -50,7 +50,7 @@ export default class PublisherNucleus extends PublisherBase<PublisherNucleusConf
for (const artifactPath of makeResult.artifacts) {
// Skip the RELEASES file, it is automatically generated on the server
if (path.basename(artifactPath).toLowerCase() === 'releases') continue;
data.append('file' + i, fs.createReadStream(artifactPath));
data.append(`file${i}`, fs.createReadStream(artifactPath));
i += 1;
}

@@ -670,17 +670,18 @@
lodash "^4.2.0"
to-fast-properties "^2.0.0"

"@fimbul/bifrost@^0.6.0":
version "0.6.0"
resolved "https://registry.yarnpkg.com/@fimbul/bifrost/-/bifrost-0.6.0.tgz#5150302b63e1bd37ff95f561c3605949cb7e3770"
"@fimbul/bifrost@^0.11.0":
version "0.11.0"
resolved "https://registry.yarnpkg.com/@fimbul/bifrost/-/bifrost-0.11.0.tgz#83cacc21464198b12e3cc1c2204ae6c6d7afd158"
dependencies:
"@fimbul/ymir" "^0.6.0"
"@fimbul/ymir" "^0.11.0"
get-caller-file "^1.0.2"
tslib "^1.8.1"
tsutils "^2.24.0"

"@fimbul/ymir@^0.6.0":
version "0.6.0"
resolved "https://registry.yarnpkg.com/@fimbul/ymir/-/ymir-0.6.0.tgz#537cb15d361b7c993fe953b48c898ecdf4f671b8"
"@fimbul/ymir@^0.11.0":
version "0.11.0"
resolved "https://registry.yarnpkg.com/@fimbul/ymir/-/ymir-0.11.0.tgz#892a01997f1f80c7e4e437cf5ca51c95994c136f"
dependencies:
inversify "^4.10.0"
reflect-metadata "^0.1.12"
@@ -2988,7 +2989,7 @@ diffie-hellman@^5.0.0:
miller-rabin "^4.0.0"
randombytes "^2.0.0"

doctrine@^0.7.2:
doctrine@0.7.2:
version "0.7.2"
resolved "https://registry.yarnpkg.com/doctrine/-/doctrine-0.7.2.tgz#7cb860359ba3be90e040b26b729ce4bfa654c523"
dependencies:
@@ -8521,43 +8522,43 @@ ts-node@^6.0.0:
source-map-support "^0.5.3"
yn "^2.0.0"

tslib@^1.0.0, tslib@^1.7.1, tslib@^1.8.0, tslib@^1.8.1:
tslib@1.9.0, tslib@^1.7.1, tslib@^1.8.0, tslib@^1.8.1:
version "1.9.0"
resolved "https://registry.yarnpkg.com/tslib/-/tslib-1.9.0.tgz#e37a86fda8cbbaf23a057f473c9f4dc64e5fc2e8"

tslib@^1.9.0:
version "1.9.3"
resolved "https://registry.yarnpkg.com/tslib/-/tslib-1.9.3.tgz#d7e4dd79245d85428c4d7e4822a79917954ca286"

tslint-config-airbnb@^5.8.0:
version "5.8.0"
resolved "https://registry.yarnpkg.com/tslint-config-airbnb/-/tslint-config-airbnb-5.8.0.tgz#0398cf4b5a8715b604cb40e9580532c5c0e68716"
tslint-config-airbnb@^5.11.0:
version "5.11.0"
resolved "https://registry.yarnpkg.com/tslint-config-airbnb/-/tslint-config-airbnb-5.11.0.tgz#4477fa64e2d8b4282b43666d6a34925c766cc949"
dependencies:
tslint-consistent-codestyle "^1.10.0"
tslint-eslint-rules "^4.1.1"
tslint-microsoft-contrib "~5.0.1"
tslint-consistent-codestyle "^1.13.3"
tslint-eslint-rules "^5.4.0"
tslint-microsoft-contrib "~5.2.0"

tslint-consistent-codestyle@^1.10.0:
version "1.13.0"
resolved "https://registry.yarnpkg.com/tslint-consistent-codestyle/-/tslint-consistent-codestyle-1.13.0.tgz#82abf230bf39e01159b4e9af721d489dd5ae0e6c"
tslint-consistent-codestyle@^1.13.3:
version "1.13.3"
resolved "https://registry.yarnpkg.com/tslint-consistent-codestyle/-/tslint-consistent-codestyle-1.13.3.tgz#763e8575accc19f17b7d0369ead382bdbf78fd5b"
dependencies:
"@fimbul/bifrost" "^0.6.0"
"@fimbul/bifrost" "^0.11.0"
tslib "^1.7.1"
tsutils "^2.24.0"
tsutils "^2.27.0"

tslint-eslint-rules@^4.1.1:
version "4.1.1"
resolved "https://registry.yarnpkg.com/tslint-eslint-rules/-/tslint-eslint-rules-4.1.1.tgz#7c30e7882f26bc276bff91d2384975c69daf88ba"
tslint-eslint-rules@^5.4.0:
version "5.4.0"
resolved "https://registry.yarnpkg.com/tslint-eslint-rules/-/tslint-eslint-rules-5.4.0.tgz#e488cc9181bf193fe5cd7bfca213a7695f1737b5"
dependencies:
doctrine "^0.7.2"
tslib "^1.0.0"
tsutils "^1.4.0"
doctrine "0.7.2"
tslib "1.9.0"
tsutils "^3.0.0"

tslint-microsoft-contrib@~5.0.1:
version "5.0.3"
resolved "https://registry.yarnpkg.com/tslint-microsoft-contrib/-/tslint-microsoft-contrib-5.0.3.tgz#6fc3e238179cd72045c2b422e4d655f4183a8d5c"
tslint-microsoft-contrib@~5.2.0:
version "5.2.1"
resolved "https://registry.yarnpkg.com/tslint-microsoft-contrib/-/tslint-microsoft-contrib-5.2.1.tgz#a6286839f800e2591d041ea2800c77487844ad81"
dependencies:
tsutils "^2.12.1"
tsutils "^2.27.2 <2.29.0"

tslint@^5.9.1:
version "5.9.1"
@@ -8576,16 +8577,30 @@ tslint@^5.9.1:
tslib "^1.8.0"
tsutils "^2.12.1"

tsutils@^1.4.0:
version "1.9.1"
resolved "https://registry.yarnpkg.com/tsutils/-/tsutils-1.9.1.tgz#b9f9ab44e55af9681831d5f28d0aeeaf5c750cb0"

tsutils@^2.12.1, tsutils@^2.24.0:
version "2.26.2"
resolved "https://registry.yarnpkg.com/tsutils/-/tsutils-2.26.2.tgz#a9f9f63434a456a5e0c95a45d9a59181cb32d3bf"
dependencies:
tslib "^1.8.1"

tsutils@^2.27.0:
version "2.29.0"
resolved "https://registry.yarnpkg.com/tsutils/-/tsutils-2.29.0.tgz#32b488501467acbedd4b85498673a0812aca0b99"
dependencies:
tslib "^1.8.1"

"tsutils@^2.27.2 <2.29.0":
version "2.28.0"
resolved "https://registry.yarnpkg.com/tsutils/-/tsutils-2.28.0.tgz#6bd71e160828f9d019b6f4e844742228f85169a1"
dependencies:
tslib "^1.8.1"

tsutils@^3.0.0:
version "3.0.0"
resolved "https://registry.yarnpkg.com/tsutils/-/tsutils-3.0.0.tgz#0c5070a17a0503e056da038c48b5a1870a50a9ad"
dependencies:
tslib "^1.8.1"

tty-browserify@0.0.0:
version "0.0.0"
resolved "https://registry.yarnpkg.com/tty-browserify/-/tty-browserify-0.0.0.tgz#a157ba402da24e9bf957f9aa69d524eed42901a6"

0 comments on commit 3618e99

Please sign in to comment.
You can’t perform that action at this time.