Skip to content
Permalink
Browse files

chore: upgrade @malept/electron-installer-flatpak to ^0.10.0 (#944)

  • Loading branch information
malept committed Jun 15, 2019
1 parent 47801d9 commit 8c8083bfed8515f0ef5a4ab3768536e27a0a5f65
Showing with 67 additions and 25 deletions.
  1. +1 −1 package.json
  2. +2 −2 packages/maker/flatpak/package.json
  3. +64 −22 yarn.lock
@@ -155,7 +155,7 @@
"typescript": "3.5.2"
},
"optionalDependencies": {
"@malept/electron-installer-flatpak": "^0.9.0",
"@malept/electron-installer-flatpak": "^0.10.0",
"electron-installer-debian": "^2.0.0",
"electron-installer-dmg": "^3.0.0",
"electron-installer-redhat": "^2.0.0",
@@ -24,6 +24,6 @@
"pify": "^4.0.0"
},
"optionalDependencies": {
"@malept/electron-installer-flatpak": "^0.9.0"
"@malept/electron-installer-flatpak": "^0.10.0"
}
}
}
@@ -744,29 +744,28 @@
got "^9.6.0"
sumchecker "^3.0.0"

"@malept/electron-installer-flatpak@^0.9.0":
version "0.9.0"
resolved "https://registry.yarnpkg.com/@malept/electron-installer-flatpak/-/electron-installer-flatpak-0.9.0.tgz#9f42f7dfa1943e81108d5e3615a76b87aba81ee7"
integrity sha512-QQJE3JJ37nyK2azDQ+cDxhzgV5O2d/VOx8005gqOAtYatf4F9GVNW1SNZmGJ8gsq/EpPOxBKOsHjLUs/gFJg1w==
"@malept/electron-installer-flatpak@^0.10.0":
version "0.10.0"
resolved "https://registry.yarnpkg.com/@malept/electron-installer-flatpak/-/electron-installer-flatpak-0.10.0.tgz#c30f161056d3e5842179caa9b20bbc188e18d46f"
integrity sha512-I84J5awVYZUQhMF5AaWcI7CXcsMO/9tNsMxH9Ivh/IuTFPtQXs0ZjQAQ9EhESP/Avynqw0Ew3v0JQfqYTpF2yA==
dependencies:
"@malept/flatpak-bundler" "^0.2.0"
"@malept/flatpak-bundler" "^0.3.0"
debug "^4.1.1"
electron-installer-common "^0.6.2"
fs-extra "^7.0.1"
electron-installer-common "^0.7.0"
fs-extra "^8.0.1"
lodash "^4.13.0"
temp "^0.9.0"
yargs "^12.0.5"
semver "^6.1.1"
yargs "^13.2.4"

"@malept/flatpak-bundler@^0.2.0":
version "0.2.0"
resolved "https://registry.yarnpkg.com/@malept/flatpak-bundler/-/flatpak-bundler-0.2.0.tgz#c7edfd1abef54b537383b70a02a0a36992d50fca"
integrity sha512-zHGJGHnsFqkp6ks79OUcgctn4J6hA7A0JHCK3S7w76syYi5pZzxzUq8v92xaIrI43Or7AcV25pBndftgO2Jq0Q==
"@malept/flatpak-bundler@^0.3.0":
version "0.3.0"
resolved "https://registry.yarnpkg.com/@malept/flatpak-bundler/-/flatpak-bundler-0.3.0.tgz#107c2343f982c61177ecc5fe0783a1bb47978258"
integrity sha512-jOp6TWc0vLpye3390Z29otyDmzwfof8SljeqeuIL6pyGszmBFx2J4hcpq1urb+3qcGs6/ZyCgUxREZGTKz+5og==
dependencies:
debug "^4.1.1"
fs-extra "^7.0.1"
fs-extra "^8.0.1"
lodash "^4.16.2"
nodeify "^1.0.1"
tmp-promise "^1.0.5"
tmp-promise "^2.0.1"

"@octokit/endpoint@^5.1.0":
version "5.1.5"
@@ -2370,6 +2369,15 @@ cliui@^4.0.0:
strip-ansi "^4.0.0"
wrap-ansi "^2.0.0"

cliui@^5.0.0:
version "5.0.0"
resolved "https://registry.yarnpkg.com/cliui/-/cliui-5.0.0.tgz#deefcfdb2e800784aa34f46fa08e06851c7bbbc5"
integrity sha512-PYeGSEmmHM6zvoef2w8TPzlrnNpXIjTipYK780YswmIP9vjxmd6Y2a3CB2Ks6/AU8NHjZugXvo8w3oWM2qnwXA==
dependencies:
string-width "^3.1.0"
strip-ansi "^5.2.0"
wrap-ansi "^5.1.0"

clone-response@^1.0.2:
version "1.0.2"
resolved "https://registry.yarnpkg.com/clone-response/-/clone-response-1.0.2.tgz#d1dc973920314df67fbeb94223b4ee350239e96b"
@@ -3133,7 +3141,7 @@ electron-download@^4.1.1:
semver "^5.4.1"
sumchecker "^2.0.2"

electron-installer-common@^0.6.2, electron-installer-common@^0.6.3:
electron-installer-common@^0.6.3:
version "0.6.3"
resolved "https://registry.yarnpkg.com/electron-installer-common/-/electron-installer-common-0.6.3.tgz#d17f5062890acaef0c7dd7972aae3a746bca921f"
integrity sha512-ylecrLzz2Qmfv9QgFBoQAcB7i51ROUXguA0EExo70LVeJznDi94vCwVSoKotC7BslmUH6Iz1vYZOyqMon8PhcA==
@@ -3149,7 +3157,7 @@ electron-installer-common@^0.6.2, electron-installer-common@^0.6.3:
semver "^6.0.0"
tmp-promise "^1.0.5"

electron-installer-common@^0.7.1:
electron-installer-common@^0.7.0, electron-installer-common@^0.7.1:
version "0.7.2"
resolved "https://registry.yarnpkg.com/electron-installer-common/-/electron-installer-common-0.7.2.tgz#034ffb3a3e393f2637a4fad29a7dfc65f1d47517"
integrity sha512-oe4HMkxB/BV7waa+LMj47aTTyjLFfkOP3Omz8rengoXhQYaSGmf2hNG058NoqzbozXM5Tjiwgh7dShUAPaVhdw==
@@ -8035,7 +8043,7 @@ string-width@^1.0.1:
is-fullwidth-code-point "^2.0.0"
strip-ansi "^4.0.0"

string-width@^3.0.0:
string-width@^3.0.0, string-width@^3.1.0:
version "3.1.0"
resolved "https://registry.yarnpkg.com/string-width/-/string-width-3.1.0.tgz#22767be21b62af1081574306f69ac51b62203961"
integrity sha512-vafcv6KjVZKSgz06oM/H6GDBrAtz8vdhQakGjFIvNrHA6y3HCF1CInLy+QLq8dTJPQ1b+KDUqDFctkdRW44e1w==
@@ -8077,7 +8085,7 @@ strip-ansi@^4.0.0:
dependencies:
ansi-regex "^3.0.0"

strip-ansi@^5.1.0, strip-ansi@^5.2.0:
strip-ansi@^5.0.0, strip-ansi@^5.1.0, strip-ansi@^5.2.0:
version "5.2.0"
resolved "https://registry.yarnpkg.com/strip-ansi/-/strip-ansi-5.2.0.tgz#8c9a536feb6afc962bdfa5b104a5091c1ad9c0ae"
integrity sha512-DuRs1gKbBqsMKIZlrffwlug8MHkcnpjs5VPmL1PAh+mA30U0DTotfDZ0d2UUsXpPmPmMMJ6W773MaA3J+lbiWA==
@@ -8984,6 +8992,15 @@ wrap-ansi@^3.0.1:
string-width "^2.1.1"
strip-ansi "^4.0.0"

wrap-ansi@^5.1.0:
version "5.1.0"
resolved "https://registry.yarnpkg.com/wrap-ansi/-/wrap-ansi-5.1.0.tgz#1fd1f67235d5b6d0fee781056001bfb694c03b09"
integrity sha512-QC1/iN/2/RPVJ5jYK8BGttj5z83LmSKmvbvrXPNCLZSEb32KKVDJDl/MOt2N01qU2H/FkzEa9PKto1BqDjtd7Q==
dependencies:
ansi-styles "^3.2.0"
string-width "^3.0.0"
strip-ansi "^5.0.0"

wrappy@1:
version "1.0.2"
resolved "https://registry.yarnpkg.com/wrappy/-/wrappy-1.0.2.tgz#b5243d8f3ec1aa35f1364605bc0d1036e30ab69f"
@@ -9079,7 +9096,7 @@ yallist@^3.0.0, yallist@^3.0.2, yallist@^3.0.3:
resolved "https://registry.yarnpkg.com/yallist/-/yallist-3.0.3.tgz#b4b049e314be545e3ce802236d6cd22cd91c3de9"
integrity sha512-S+Zk8DEWE6oKpV+vI3qWkaK+jSbIK86pCwe2IF/xwIpQ8jEuxpw9NyaGjmp9+BoJv5FV2piqCDcoCtStppiq2A==

yargs-parser@13.0.0, yargs-parser@^13.0.0:
yargs-parser@13.0.0:
version "13.0.0"
resolved "https://registry.yarnpkg.com/yargs-parser/-/yargs-parser-13.0.0.tgz#3fc44f3e76a8bdb1cc3602e860108602e5ccde8b"
integrity sha512-w2LXjoL8oRdRQN+hOyppuXs+V/fVAYtpcrRxZuF7Kt/Oc+Jr2uAcVntaUTNT6w5ihoWfFDpNY8CPx1QskxZ/pw==
@@ -9095,6 +9112,14 @@ yargs-parser@^11.1.1:
camelcase "^5.0.0"
decamelize "^1.2.0"

yargs-parser@^13.0.0, yargs-parser@^13.1.0:
version "13.1.1"
resolved "https://registry.yarnpkg.com/yargs-parser/-/yargs-parser-13.1.1.tgz#d26058532aa06d365fe091f6a1fc06b2f7e5eca0"
integrity sha512-oVAVsHz6uFrg3XQheFII8ESO2ssAf9luWuAd6Wexsu4F3OtIW0o8IribPXYrD4WC24LWtPrJlGy87y5udK+dxQ==
dependencies:
camelcase "^5.0.0"
decamelize "^1.2.0"

yargs-unparser@1.5.0:
version "1.5.0"
resolved "https://registry.yarnpkg.com/yargs-unparser/-/yargs-unparser-1.5.0.tgz#f2bb2a7e83cbc87bb95c8e572828a06c9add6e0d"
@@ -9104,7 +9129,7 @@ yargs-unparser@1.5.0:
lodash "^4.17.11"
yargs "^12.0.5"

yargs@13.2.2, yargs@^13.2.2:
yargs@13.2.2:
version "13.2.2"
resolved "https://registry.yarnpkg.com/yargs/-/yargs-13.2.2.tgz#0c101f580ae95cea7f39d927e7770e3fdc97f993"
integrity sha512-WyEoxgyTD3w5XRpAQNYUB9ycVH/PQrToaTXdYXRdOXvEy1l19br+VJsc0vcO8PTGg5ro/l/GY7F/JMEBmI0BxA==
@@ -9139,6 +9164,23 @@ yargs@^12.0.5:
y18n "^3.2.1 || ^4.0.0"
yargs-parser "^11.1.1"

yargs@^13.2.2, yargs@^13.2.4:
version "13.2.4"
resolved "https://registry.yarnpkg.com/yargs/-/yargs-13.2.4.tgz#0b562b794016eb9651b98bd37acf364aa5d6dc83"
integrity sha512-HG/DWAJa1PAnHT9JAhNa8AbAv3FPaiLzioSjCcmuXXhP8MlpHO5vwls4g4j6n30Z74GVQj8Xa62dWVx1QCGklg==
dependencies:
cliui "^5.0.0"
find-up "^3.0.0"
get-caller-file "^2.0.1"
os-locale "^3.1.0"
require-directory "^2.1.1"
require-main-filename "^2.0.0"
set-blocking "^2.0.0"
string-width "^3.0.0"
which-module "^2.0.0"
y18n "^4.0.0"
yargs-parser "^13.1.0"

yarn-or-npm@^2.0.2:
version "2.0.4"
resolved "https://registry.yarnpkg.com/yarn-or-npm/-/yarn-or-npm-2.0.4.tgz#46e38aafce74c350e6c0cca72712fca7410fad98"

0 comments on commit 8c8083b

Please sign in to comment.
You can’t perform that action at this time.