Skip to content
Permalink
Browse files

fix(importer): update the logging as per PR feedback

  • Loading branch information
MarshallOfSound authored and malept committed Dec 16, 2016
1 parent b09fc3d commit dac33f0d561fcb4e1895c7f2731fa4f83baab41a
Showing with 16 additions and 9 deletions.
  1. +15 −8 src/electron-forge-import.js
  2. +1 −1 src/init/init-npm.js
@@ -66,7 +66,7 @@ const main = async () => {
const { shouldChangeMain } = await inquirer.createPromptModule()({
type: 'confirm',
name: 'shouldChangeMain',
message: 'Do you want us to change the "main" attribute of your package.json? If you are currently using babel and pointint to a "build" directory say yes.', // eslint-disable-line
message: 'Do you want us to change the "main" attribute of your package.json? If you are currently using babel and pointing to a "build" directory say yes.', // eslint-disable-line
});
if (shouldChangeMain) {
const { newMain } = await inquirer.createPromptModule()({
@@ -170,13 +170,20 @@ const main = async () => {
babelSpinner.succeed();
console.info('NOTE: You might be able to remove your `.compilerc` file completely if you are only using the `es2015` and `react` presets'.yellow);
}
/* eslint-disable prefer-template */
console.info('\n\nWe have ATTEMPTED to convert your app to be in a format that electron-forge understands.\nNothing much will have changed but we added the' +
' "electron-prebuilt-compile" '.cyan +
'dependency. This is the dependency you must version bump to get newer versions of Electron.\n\n' +
'We also tried to import any build tooling you already had but we can\'t get everything. You might need to convert any CLI/gulp/grunt tasks yourself.\n\n' +
'Also please note if you are using `preload` scripts you need to follow the steps outlined at https://github.com/electron-userland/electron-forge/wiki/Using-\'preload\'-scripts\n\n' +
'Thanks for using ' + 'electron-forge'.green + '!!!');

console.info(`
We have ATTEMPTED to convert your app to be in a format that electron-forge understands.
Nothing much will have changed but we added the ${'"electron-prebuilt-compile"'.cyan} dependency. This is \
the dependency you must version bump to get newer versions of Electron.
We also tried to import any build tooling you already had but we can't get everything. You might need to convert any CLI/gulp/grunt tasks yourself.
Also please note if you are using \`preload\` scripts you need to follow the steps outlined \
at https://github.com/electron-userland/electron-forge/wiki/Using-%27preload%27-scripts
Thanks for using ${'"electron-forge"'.green}!!!`);
};

main();
@@ -30,7 +30,7 @@ export default async (dir, lintStyle) => {
packageJSON.scripts.lint = 'eslint src';
break;
default:
packageJSON.scripts.lint = 'echo "No linting yet..."';
packageJSON.scripts.lint = 'echo "No linting configured"';
break;
}
d('writing package.json to:', dir);

0 comments on commit dac33f0

Please sign in to comment.
You can’t perform that action at this time.