New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Electron 4.0.0 uses a too recent glibc for Raspberry PI #16205

Open
manast opened this Issue Dec 27, 2018 · 11 comments

Comments

Projects
None yet
9 participants
@manast
Copy link

manast commented Dec 27, 2018

  • Output of node_modules/.bin/electron --version:
    v4.0.0

  • Operating System (Platform and Version):
    Raspbian 2.6 (latest raspbian at the time of filling the issue).

  • Output of node_modules/.bin/electron --version on last known working Electron version (if applicable):
    V3.0.10

Expected Behavior
Electron 4 should work on RPI as Electron 3 does.

Actual behavior
Starting an electron 4 app results in this error:
/lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.27' not found
Latest Rapsbian includes GLIBC 2.23.

To Reproduce
Just build an electron 4.0.0 app for RPI and run it on latest raspbian.

@welcome

This comment has been minimized.

Copy link

welcome bot commented Dec 27, 2018

👋 Thanks for opening your first issue here! If you're reporting a 🐞 bug, please make sure you include steps to reproduce it. We get a lot of issues on this repo, so please be patient and we will get back to you as soon as we can.

To help make it easier for us to investigate your issue, please follow the contributing guidelines.

@manast

This comment has been minimized.

Copy link

manast commented Dec 27, 2018

Ok, it seems even worse than I thought, even older versions are now delivering binaries that are not compatible with RPI. Could it be that someone made a mistake and re-built all old binaries for arm using a newer GLIBC?

@felixrieseberg

This comment has been minimized.

Copy link
Member

felixrieseberg commented Dec 27, 2018

Nobody went and rebuild all older versions 😅 When you're saying that older versions don't work either, which versions do you mean?

In addition, would you mind elaborating why updating libc isn't the right solution?

@manast

This comment has been minimized.

Copy link

manast commented Dec 27, 2018

@felixrieseberg yeah, I also find it strange. But going back to 3.0.10 and building with electron-builder creates a build that is dependent on glibc >= 2.27.
The reason this is bad is because raspbian only support 2.23 which makes electron incompatible with RPI...

@kwonoj

This comment has been minimized.

Copy link
Member

kwonoj commented Dec 27, 2018

building with electron-builder creates a build that is dependent

What happens if running bare electron binary or packaging without electron-builder?

@izuchukwu

This comment has been minimized.

Copy link

izuchukwu commented Dec 28, 2018

I'm currently experiencing this as well. Downloading glibc 2.27 (and 2.28) and using LD_LIBRARY_PATH led to the message "Segmentation fault". I'm not building using electron-builder however, and downgrading to v3.0.13 got Electron working for me.

@willswire

This comment has been minimized.

Copy link

willswire commented Jan 2, 2019

Can confirm this on my end as well; deploying to multiple raspberry units (3b/3b+)

/usr/src/app/node_modules/electron/dist/electron: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.27' not found (required by /usr/src/app/node_modules/electron/dist/electron)

@willswire

This comment has been minimized.

Copy link

willswire commented Jan 10, 2019

Testing with Debian Buster, Electron 4.0.0 works. This is because Buster includes a glibc library that is compatible.

@huiyifyj

This comment has been minimized.

Copy link

huiyifyj commented Jan 14, 2019

It seems that most of Raspberry card can't run electron normally.
Hope can solve the libc dependence as soon as possible.

@bpasero

This comment has been minimized.

Copy link
Contributor

bpasero commented Jan 15, 2019

This also seems to prevent running Electron 4.0.x on a Ubuntu 14 32bits: #16407

@andrei-tara

This comment has been minimized.

Copy link

andrei-tara commented Jan 15, 2019

Same issue here :(

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment