New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

After I import {ipcRenderer} from 'electron' in renderer,I have to add target: 'node' in webpack.config.js to let ipcRenderer work. #16371

Open
hugetiny opened this Issue Jan 12, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@hugetiny
Copy link

hugetiny commented Jan 12, 2019

after I import {ipcRenderer} from 'electron' in renderer

reproduce:
add target: 'node' in webpack.config.js or ipcRenderer will not work.
but there comes warning:
Electron Security Warning (Insecure Content-Security-Policy) This renderer process has either no Content Security
Policy set or a policy with "unsafe-eval" enabled. This exposes users of
this app to unnecessary security risks.

For more information and help, consult
https://electronjs.org/docs/tutorial/security.
This warning will not show up
once the app is packaged.
is {target: 'node'} required for render when i package my app with webpack?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment