Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

User agent not working (e.g. whatsapp web) #20218

Closed
DerC988 opened this issue Sep 12, 2019 · 1 comment
Closed

User agent not working (e.g. whatsapp web) #20218

DerC988 opened this issue Sep 12, 2019 · 1 comment

Comments

@DerC988
Copy link

@DerC988 DerC988 commented Sep 12, 2019

Preflight Checklist

  • I have read the Contributing Guidelines for this project.
  • I agree to follow the Code of Conduct that this project adheres to.
  • I have searched the issue tracker for an issue that matches the one I want to file, without success. <- at least I hope so oO

Issue Details

  • Electron Version:
    • 6.0.8 (older versions, e.g. 6.0.6, tested as well)
  • Operating System:
    • macOS 10.13.6 / Windows 10 (1903)
  • Last Known Working Electron version:
    • none ._.

Currently I'm playing around with basic electron stuff to get in touch with it. I've made a simple app which simply loads the page https://web.whatsapp.com.

Code:

const { app, BrowserWindow, Menu } = require('electron')
const { webContents } = require('electron')
const {dialog} = require('electron')
const myUserAgent = 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.110 Safari/537.36 '

win.loadURL('https://web.whatsapp.com/', {userAgent: myUserAgent})

Expected Behavior

Whatsapp Web loading and fully working every time you load the page.

Actual Behavior

On first startup either via npm start or starting the build app on windows and/or macOS Whatsapp Web is working fine. After restarting the app or reloading the URL it asks me to update to Google Chrome 49+. After removing C:\Users\MyUser\AppData\Roaming\AppName and starting the app everything works flawless. After restarting the mentioned 'update to Google Chrome 49+' screen pops up again. Tried several user agents.

To Reproduce

Create sample app and load Whatsapp Web via
win.loadURL('https://web.whatsapp.com/', {userAgent: myUserAgent})

Is this something I've spoiled?

Cheers :)

@MarshallOfSound

This comment has been minimized.

Copy link
Member

@MarshallOfSound MarshallOfSound commented Sep 12, 2019

GitHub issues are for feature requests and bug reports, questions about using Electron or code assistance requests should be directed to the community or to the Slack Channel.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.