Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

chore: update to latest TypeScript 3.5.2 #19133

Merged
merged 1 commit into from Jul 9, 2019

Conversation

Projects
None yet
4 participants
@miniak
Copy link
Contributor

commented Jul 6, 2019

Description of Change

Update to latest TypeScript 3.5.2 + yarn upgrade transitive dependencies to latest versions.
Required by #18820

Checklist

  • PR description included and stakeholders cc'd
  • npm test passes
  • PR title follows semantic commit guidelines

Release Notes

Notes: no-notes

@miniak

This comment has been minimized.

Copy link
Contributor Author

commented Jul 6, 2019

I was getting this error after updating just TypeScript

=============

WARNING: You are currently running a version of TypeScript which is not officially supported by typescript-estree.

You may find that it works just fine, or you may not.

SUPPORTED TYPESCRIPT VERSIONS: >=3.2.1 <3.5.0

YOUR TYPESCRIPT VERSION: 3.5.2

Please only submit bug reports when using the officially supported version.

=============

It was caused by typescript-estree, which could be fixed by yarn upgrade

@miniak miniak self-assigned this Jul 6, 2019

@miniak miniak requested review from codebytere and MarshallOfSound Jul 6, 2019

@miniak miniak referenced this pull request Jul 6, 2019

Open

chore: convert more files to TypeScript #18820

3 of 3 tasks complete

@miniak miniak force-pushed the miniak/update-typescript branch from 41535c8 to df88722 Jul 6, 2019

@MarshallOfSound

This comment has been minimized.

Copy link
Member

commented Jul 7, 2019

Please do not merge with the above warnings 👍 Upgrading the eslint ts plugins and such should remove that warning

@miniak

This comment has been minimized.

Copy link
Contributor Author

commented Jul 7, 2019

@MarshallOfSound upgrading transitive dependencies via yarn upgrade fixed the warning. It was caused by typescript-estree, which we don't depend on directly.

@miniak

This comment has been minimized.

Copy link
Contributor Author

commented Jul 7, 2019

Also this PR #18340 removed all the checksums, should we enforce a minimum version of yarn to make sure it does not happen again?

@electron-cation electron-cation bot removed the new-pr 🌱 label Jul 7, 2019

@miniak miniak requested a review from nornagon Jul 8, 2019

@zcbenz

zcbenz approved these changes Jul 9, 2019

@zcbenz

This comment has been minimized.

Copy link
Member

commented Jul 9, 2019

Looks good to me as the warning is resolved,

@miniak miniak force-pushed the miniak/update-typescript branch from df88722 to 320fff1 Jul 9, 2019

@alexeykuzmin alexeykuzmin merged commit fdbb97e into master Jul 9, 2019

13 checks passed

Artifact Comparison No Changes
Details
Semantic Pull Request ready to be squashed
Details
WIP Ready for review
Details
appveyor: win-ia32-testing AppVeyor build succeeded
Details
appveyor: win-ia32-testing-pr AppVeyor build succeeded
Details
appveyor: win-x64-testing AppVeyor build succeeded
Details
appveyor: win-x64-testing-pr AppVeyor build succeeded
Details
build-linux Workflow: build-linux
Details
build-mac Workflow: build-mac
Details
electron-arm-testing Build #20190709.13 succeeded
Details
electron-arm64-testing Build #20190709.13 succeeded
Details
lint Workflow: lint
Details
release-notes Release notes found
@release-clerk

This comment has been minimized.

Copy link

commented Jul 9, 2019

No Release Notes

@miniak miniak deleted the miniak/update-typescript branch Jul 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.