Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Animation load twice on page refresh in chrome #6945

Closed
manektechmayank opened this Issue Feb 1, 2019 · 6 comments

Comments

Projects
None yet
3 participants
@manektechmayank
Copy link

commented Feb 1, 2019

Prerequisites

  • I have searched for similar issues in both open and closed tickets and cannot find a duplicate.
  • The issue still exists against the latest stable version of Elementor.

Description

I have created 3 images. And given animation "left", "right" and "bottom" accordingly. When I scroll the page it's working fine. But when refresh the page, then animation happen twice. Means it start the animation twice in Chrome browser.

Steps to reproduce

  1. Create any section using elementor plugin.
  2. Add 3 image by using "image widget".
  3. Then give the positioning of image using margin so that they will look like below image.

image

  1. Now it will work fine on first time page load but If you refresh the page then it will look like start twice animation.

Please check this video so that you can see clear issue of animation : https://www.screencast.com/t/7IPLqrKym5Jx

Isolating the problem

  • This bug happens with only Elementor plugin active (and Elementor Pro).
  • This bug happens with a default WordPress theme active.
  • I can reproduce this bug consistently using the steps above.

Environment

System Info ```

== Server Environment ==
Operating System: Linux
Software: Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/7.2.9
MySQL version: MySQL Community Server (GPL) v5.7.12
PHP Version: 7.2.9
PHP Max Input Vars: 1000
PHP Max Post Size: 8M
GD Installed: Yes
ZIP Installed: No
Write Permissions: All right
Elementor Library: Connected

== WordPress Environment ==
Version: 5.0.3
Site URL: http://localhost
Home URL: http://localhost
WP Multisite: No
Max Upload Size: 2 MB
Memory limit: 256M
Permalink Structure: /%postname%/
Language: en-US
Timezone: 0
Debug Mode: Inactive

== Theme ==
Name: Elementor Hello Theme
Version: 1.0
Author: Elementor Team
Child Theme: No

== User ==
Role: administrator
WP Profile lang: en_US
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.81 Safari/537.36

== Active Plugins ==
BackupBuddy
Version: 8.3.5.0
Author: iThemes

Classic Editor
	Version: 1.3
	Author: WordPress Contributors

Custom Post Type UI
	Version: 1.6.1
	Author: WebDevStudios

Duplicate Post
	Version: 3.2.2
	Author: Enrico Battocchi

Elementor
	Version: 2.4.4
	Author: Elementor.com

Elementor Extras
	Version: 2.0.8
	Author: Namogo

Elementor Pro
	Version: 2.4.2
	Author: Elementor.com

Elementor Siteset
	Version: 1.4.1
	Author: Elementor Siteset

== Log ==
:
Log: showing 2 of 22019-01-28 15:45:20 [info] Elementor data updater process has been completed. [array (
'plugin' => 'Elementor',
'from' => '2.4.1',
'to' => '2.4.4',
)]
2019-01-28 15:45:32 [info] Elementor data updater process has been completed. [array (
'plugin' => 'Elementor Pro',
'from' => '2.3.1',
'to' => '2.4.2',
)]

JS: showing 2 of 2JS: 2019-01-28 20:24:49 [error X 3][http://localhost/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.4:2:6883] Cannot read property 'select2' of undefined
JS: 2019-02-01 04:40:07 [error X 5][http://localhost/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.4:2:74537] setting getter-only property "type"

@shilo-ey

This comment has been minimized.

Copy link
Collaborator

commented Feb 3, 2019

Hi @manektechmayank

Thanks for reporting.

We couldn't reproduce your issue (after recreating the same layout & attributes) and therefore we suggest you to try deactivating all of your plugins except Elementor & Elementor Pro, and see if it resolved.

thanks.

@shilo-ey shilo-ey closed this Feb 3, 2019

@wayheming

This comment has been minimized.

Copy link
Contributor

commented Feb 5, 2019

Hello @shilo-ey I have the same problem https://gyazo.com/1e05762189d7c3315efbe8b858734497
This is JSON to demonstrate the problem

{"version":"0.4","title":"Animations bug","type":"page","content":[{"id":"474cdbbc","settings":{"structure":"30","background_background":"classic","background_color":"#4054b2","padding":{"unit":"px","top":"55","right":"55","bottom":"55","left":"55","isLinked":true}},"elements":[{"id":"51a3e41b","settings":{"_column_size":33,"_inline_size":null},"elements":[{"id":"84026da","settings":{"title_text":"This is the heading","description_text":"Click edit button to change this text. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut elit tellus, luctus nec ullamcorper mattis, pulvinar dapibus leo.","_animation":"slideInUp","_animation_delay":400},"elements":[],"isInner":false,"widgetType":"icon-box","elType":"widget"},{"id":"4993da5c","settings":{"title_text":"This is the heading","description_text":"Click edit button to change this text. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut elit tellus, luctus nec ullamcorper mattis, pulvinar dapibus leo.","_animation":"slideInUp","_animation_delay":600},"elements":[],"isInner":false,"widgetType":"icon-box","elType":"widget"}],"isInner":false,"elType":"column"},{"id":"70f72945","settings":{"_column_size":33,"_inline_size":null},"elements":[{"id":"3208bd41","settings":{"title_text":"This is the heading","description_text":"Click edit button to change this text. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut elit tellus, luctus nec ullamcorper mattis, pulvinar dapibus leo.","_animation":"slideInUp","_animation_delay":400},"elements":[],"isInner":false,"widgetType":"icon-box","elType":"widget"},{"id":"587c938c","settings":{"title_text":"This is the heading","description_text":"Click edit button to change this text. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut elit tellus, luctus nec ullamcorper mattis, pulvinar dapibus leo.","_animation":"slideInUp","_animation_delay":600},"elements":[],"isInner":false,"widgetType":"icon-box","elType":"widget"}],"isInner":false,"elType":"column"},{"id":"7e3b98d7","settings":{"_column_size":33,"_inline_size":null},"elements":[{"id":"6bd8dfe3","settings":{"title_text":"This is the heading","description_text":"Click edit button to change this text. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut elit tellus, luctus nec ullamcorper mattis, pulvinar dapibus leo.","_animation":"slideInUp","_animation_delay":400},"elements":[],"isInner":false,"widgetType":"icon-box","elType":"widget"},{"id":"6a3ff30f","settings":{"title_text":"This is the heading","description_text":"Click edit button to change this text. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Ut elit tellus, luctus nec ullamcorper mattis, pulvinar dapibus leo.","_animation":"slideInUp","_animation_delay":600},"elements":[],"isInner":false,"widgetType":"icon-box","elType":"widget"}],"isInner":false,"elType":"column"}],"isInner":false,"elType":"section"}]}
@wayheming

This comment has been minimized.

Copy link
Contributor

commented Feb 5, 2019

I think the problem with slide animations.

@shilo-ey

This comment has been minimized.

Copy link
Collaborator

commented Feb 5, 2019

Hi @manektechmayank & @wayheming

This issue has been fixed in the upcoming major version.

Thanks

@shilo-ey shilo-ey reopened this Feb 5, 2019

@shilo-ey shilo-ey added this to the 2.5.0 milestone Feb 5, 2019

@wayheming

This comment has been minimized.

Copy link
Contributor

commented Feb 5, 2019

Hello @shilo-ey,
thanks for the quick response as always.

@shilo-ey

This comment has been minimized.

Copy link
Collaborator

commented Mar 4, 2019

This has been fixed in Elementor v2.5.0

Feel free to update!

@shilo-ey shilo-ey closed this Mar 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.