Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Can we remove dependency on 'activeadmin', '~> 0.6.1'? #66

Open
OptimisticMonkey opened this Issue · 5 comments

4 participants

@OptimisticMonkey

It seems activeadmin has been updated to 1.0.0.pre which breaks dependency
gem.add_runtime_dependency 'activeadmin', '~> 0.6.1'

I am trying to deploy on heroku

Bundler could not find compatible versions for gem "activeadmin":
In Gemfile:
activeadmin-mongoid (>= 0) ruby depends on
activeadmin (~> 0.6.1) ruby

activeadmin (1.0.0.pre)
@elia
Owner

I'm using a strict dependency requirements to have less troubles with conflict resolution and a clear target. This project is just a big hack with no support nor compatibility from activeadmin or mongoid.

My advice is to fork, bump the version requirements and if everything goes well send me a PR :)

@chenkirk

I am trying to do the same thing.

I forked to Grantoo/activeadmin-mongoid, changed it to:

gem.add_runtime_dependency 'activeadmin', '~> 1.0.0.pre'

Now when I do a bundle update it is asking for activesupport ~> 3.1.0.alpha, but I can't find where it is needing that.

Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    activeadmin-mongoid (>= 0) ruby depends on
      activesupport (~> 3.1.0.alpha) ruby

    activesupport (4.0.2)

I am fairly new to working with gems. What am I missing?

(If everything goes well I'll do a clean branch and a PR)

@elia
Owner

@chenkirk please do the PR

To sort that kind of obscure conflicts a PR (bundler/bundler#2756) has landed into bundler that will print the full list of dependencies, I tried it locally and works perfectly :)

Let me know if you need help on installing bundler from source

@chenkirk

@elia that got me further.

Now I am stuck at the meta_search gem. It is still on 3.x activesupport and activerecord.

It look like meta_search is inactive though. Last commit was 2 years ago.

@gersmann

Hi @chenkirk,

I got a valid configuration in my Gemfile right now. Just in case you are interested. The currrent active admin version is not without bugs, though. For me filters are not working, I didn't test yet if this is due to some upgrade issues or if it's a general issue of the current commit.

#activeadmin
gem 'responders', github: 'plataformatec/responders'
gem 'activeadmin', github: 'gregbell/active_admin'
gem 'activeadmin-mongoid', github: 'gersmann/activeadmin-mongoid', branch: 'rails4'
gem 'formtastic', '>= 2.3.0.rc2'

Kind regards,

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.