Skip to content
No description, website, or topics provided.
Jupyter Notebook
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.envrc
.gitignore
LICENSE
README.md
hello-world.ipynb
requirements.txt

README.md

Turi Create on macOS

System Requirements

  • macOS version 10.12+

Setup

The latest version of Turi Create does not support Python 3.7.x so you’ll need to install 3.6.x in your environment.

Turi Create takes advantage of host OS (macOS) so containerization is not the ideal solution for speed.

Install following tools to isolate your host development environment from project specific environment.

  • xcode-select --install (to resolve zlib not available issue)
  • Install Python 3.6.8 with pyenv
  • Install virtualenv
  • Install direnv

Troubleshooting zlib not available

  • Try xcode-select --install
  • Try CFLAGS="-I$(xcrun --show-sdk-path)/usr/include" pyenv install 3.6.8

Resources on using above tools together

Install dependencies

cd /path/to/repo
pip install -r requirements.txt

Start Jupyter Notebook

jupyter notebook
You can’t perform that action at this time.