Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Added support for Elm 0.19.1 #114

Merged
merged 1 commit into from Dec 1, 2019
Merged

Added support for Elm 0.19.1 #114

merged 1 commit into from Dec 1, 2019

Conversation

@pdamoc
Copy link
Contributor

pdamoc commented Nov 26, 2019

Summary of changes:

  1. Elm app has been updated to 0.19.1, I have made changes that ignore the patch release (0.19.0 will be treated as 0.19.1, no warning about the code being made with an older version)

  2. I have updated goon to the amd-64 version for development. The i386 version was not working on my machine.

  3. Because the binary release for elm was not packed with tar I have added some code that changes the unpack command (use gunzip for elm.gz).

  4. The biggest change that needs testing and extra attention is the change in the management of dependencies for projects. For 0.19.0 and 0.19.1 the missing dependencies are installed with elm install rather than by editing the elm.json. This was done because elm was complaining about manually edited elm.json.

@tbash
tbash approved these changes Dec 1, 2019
Copy link
Member

tbash left a comment

I'm going to pull this into master, make some other changes and cut a release.

Thank you!

@tbash tbash merged commit b2df69e into ellie-app:master Dec 1, 2019
@pdamoc pdamoc deleted the pdamoc:elixir_1.7 branch Dec 4, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.