Permalink
Switch branches/tags
svn-trunk liboping-0.1.0 collectd-4.10.1 collectd-4.10.0 collectd-4.9.3 collectd-4.9.2 collectd-4.9.1 collectd-4.9.0 collectd-4.8.5 collectd-4.8.4 collectd-4.8.3 collectd-4.8.2 collectd-4.8.1 collectd-4.8.0 collectd-4.7.5 collectd-4.7.4 collectd-4.7.3 collectd-4.7.2 collectd-4.7.1 collectd-4.7.0 collectd-4.6.5 collectd-4.6.4 collectd-4.6.3 collectd-4.6.2 collectd-4.6.1 collectd-4.6.0 collectd-4.5.4 collectd-4.5.3 collectd-4.5.2 collectd-4.5.1 collectd-4.5.0 collectd-4.4.5 collectd-4.4.4 collectd-4.4.3 collectd-4.4.2 collectd-4.4.1 collectd-4.4.0 collectd-4.3.4 collectd-4.3.3 collectd-4.3.2 collectd-4.3.1 collectd-4.3.0 collectd-4.3.0beta1 collectd-4.3.0beta0 collectd-4.2.7 collectd-4.2.6 collectd-4.2.5 collectd-4.2.4 collectd-4.2.3 collectd-4.2.2 collectd-4.2.1 collectd-4.2.0 collectd-4.1.6 collectd-4.1.5 collectd-4.1.4 collectd-4.1.3 collectd-4.1.2 collectd-4.1.1 collectd-4.1.0 collectd-4.0.9 collectd-4.0.8 collectd-4.0.7 collectd-4.0.6 collectd-4.0.5 collectd-4.0.4 collectd-4.0.3 collectd-4.0.2 collectd-4.0.1 collectd-4.0.0 collectd-3.11.7 collectd-3.11.6 collectd-3.11.5 collectd-3.11.4 collectd-3.11.3 collectd-3.11.2 collectd-3.11.1 collectd-3.11.0 collectd-3.10.4 collectd-3.10.3 collectd-3.10.2 collectd-3.10.1 collectd-3.10.0 collectd-3.9.4 collectd-3.9.3 collectd-3.9.2 collectd-3.9.1 collectd-3.9.0 collectd-3.8.6 collectd-3.8.5 collectd-3.8.4 collectd-3.8.3 collectd-3.8.2 collectd-3.8.1 collectd-3.8.0 collectd-3.7.2 collectd-3.7.1 collectd-3.7.0 collectd-3.6.2 collectd-3.6.1 collectd-3.6.0
Nothing to show
Find file
Fetching contributors…
Cannot retrieve contributors at this time
executable file 60 lines (51 sloc) 1.24 KB
#! /bin/sh
GLOBAL_ERROR_INDICATOR=0
check_for_application ()
{
for PROG in "$@"
do
which "$PROG" >/dev/null 2>&1
if test $? -ne 0; then
cat >&2 <<EOF
WARNING: \`$PROG' not found!
Please make sure that \`$PROG' is installed and is in one of the
directories listed in the PATH environment variable.
EOF
GLOBAL_ERROR_INDICATOR=1
fi
done
}
check_for_application lex yacc autoheader aclocal automake autoconf
# Actually we don't need the pkg-config executable, but we need the M4 macros.
# We check for `pkg-config' here and hope that M4 macros will then be
# available, too.
check_for_application pkg-config
libtoolize=""
libtoolize --version >/dev/null 2>/dev/null
if test $? -eq 0
then
libtoolize=libtoolize
else
glibtoolize --version >/dev/null 2>/dev/null
if test $? -eq 0
then
libtoolize=glibtoolize
else
cat >&2 <<EOF
WARNING: Neither \`libtoolize' nor \`glibtoolize' have been found!
Please make sure that one of them is installed and is in one of the
directories listed in the PATH environment variable.
EOF
GLOBAL_ERROR_INDICATOR=1
fi
fi
if test "$GLOBAL_ERROR_INDICATOR" != "0"
then
exit 1
fi
set -x
autoheader \
&& aclocal \
&& $libtoolize --ltdl --copy --force \
&& automake --add-missing --copy \
&& autoconf