New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

239.2 test fail #99

Closed
udeved opened this Issue Nov 23, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@udeved
Copy link

udeved commented Nov 23, 2018

Hi Sven,

Just want to let you know, referencing #85, there is still something wrong with c locales, whereas the test passes with en utf-8 locale.

snippet from meson log

 86/136 test-format-table                       FAIL     0.01 s (killed by signal 6 SIGABRT)

--- command ---
PATH='/build/elogind/src/build:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl' /build/elogind/src/build/test-format-table
--- stderr ---
Assertion 'streq(formatted, "NAME  TYPE RO  USAGE CREATED                    MODIFIED                   \n" "foooo raw  no 673.6M Wed 2018-07-11 00:10:33 J… Wed 2018-07-11 00:16:00 JST\n" )' failed at ../elogind-239.2/src/test/test-format-table.c:32, function test_issue_9549(). Aborting.
-------

@Yamakuzure Yamakuzure self-assigned this Nov 24, 2018

@Yamakuzure Yamakuzure added the bug label Nov 24, 2018

@Yamakuzure

This comment has been minimized.

Copy link
Collaborator

Yamakuzure commented Nov 24, 2018

Dammit! I thought I have caught them all. :-(

@Yamakuzure

This comment has been minimized.

Copy link
Collaborator

Yamakuzure commented Nov 24, 2018

Oh dear... when migrating the latest stream of commits (backports) in systemd-stable/v239-stable, I dug through the changes/additions to the tests because of #85 and have missed that one.

Sorry for the inconvenience this caused!

Yamakuzure added a commit that referenced this issue Nov 26, 2018

Prep v239.4: Another Unicode test has slithered in. (#99)
When migrating the latest stable commits, another test that requires
an Unicode locale has made its way back in undetected.

Bug: #99
Signed-Off-By: Sven Eden <sven.eden@prydeworx.com>
@Yamakuzure

This comment has been minimized.

Copy link
Collaborator

Yamakuzure commented Nov 26, 2018

It should work now.

@Yamakuzure Yamakuzure closed this Nov 26, 2018

Yamakuzure added a commit that referenced this issue Dec 7, 2018

Version 239.3 Release
This is a service release, bringing the following changes and fixes:

Fixes:
 * Clean up bus_creds_dump()
 * Fix documentation to refer to elogind. (#98)
 * Fixed another Unicode test that has slithered in. (#99)

Changes / Additions:
 * sd_bus_creds_get_[user_]slice() simplified.
 * Updated documentation to be more consistent (#98)
 * Also search machine-id in the dbus default path. (#100)
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment