Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

gem versions

  • Loading branch information...
commit 84844cac651dd7f26910024b2c9b0ec5e9ba9203 1 parent 45590c9
@elsifaka authored
View
4 .gitignore
@@ -3,4 +3,6 @@ log/*.log
pkg/
test/dummy/db/*.sqlite3
test/dummy/log/*.log
-test/dummy/tmp/
+test/dummy/tmp/
+*.swp
+.rvmrc
View
7 Gemfile
@@ -12,7 +12,6 @@ gemspec
# To use debugger
# gem 'ruby-debug19', :require => 'ruby-debug'
-source 'http://rubygems.org'
gem 'rails', '~> 3.2.0'
@@ -30,7 +29,6 @@ gem 'ransack'
gem 'friendly_id', '~> 4.0.0.beta14'
gem 'ancestry'
-gem 'jquery-rails'
gem 'json'
@@ -44,8 +42,6 @@ group :assets do
gem 'therubyracer'
end
-gem 'jquery-rails'
-
# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'
@@ -59,9 +55,6 @@ gem 'jquery-rails'
# gem 'ruby-debug'
group :development do
- # Deploy with Capistrano
- gem 'capistrano'
- gem 'mongrel', '> 1.2.0.pre2'
end
# To use debugger
View
175 Gemfile.lock
@@ -2,158 +2,136 @@ PATH
remote: .
specs:
reusable_containers (0.0.1)
- rails (~> 3.1.1)
+ rails (~> 3.2.1)
GEM
remote: http://rubygems.org/
- remote: http://rubygems.org/
specs:
- actionmailer (3.1.1)
- actionpack (= 3.1.1)
- mail (~> 2.3.0)
- actionpack (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
+ actionmailer (3.2.1)
+ actionpack (= 3.2.1)
+ mail (~> 2.4.0)
+ actionpack (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
builder (~> 3.0.0)
erubis (~> 2.7.0)
- i18n (~> 0.6)
- rack (~> 1.3.2)
+ journey (~> 1.0.1)
+ rack (~> 1.4.0)
rack-cache (~> 1.1)
- rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.0.2)
- activemodel (3.1.1)
- activesupport (= 3.1.1)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.1)
+ activesupport (= 3.2.1)
builder (~> 3.0.0)
- i18n (~> 0.6)
- activerecord (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- arel (~> 2.2.1)
+ activerecord (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ arel (~> 3.0.0)
tzinfo (~> 0.3.29)
- activeresource (3.1.1)
- activemodel (= 3.1.1)
- activesupport (= 3.1.1)
- activesupport (3.1.1)
+ activeresource (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ activesupport (3.2.1)
+ i18n (~> 0.6)
multi_json (~> 1.0)
ancestry (1.2.4)
activerecord (>= 2.2.2)
- ansi (1.4.1)
- arel (2.2.1)
+ ansi (1.4.2)
+ arel (3.0.0)
builder (3.0.0)
- capistrano (2.9.0)
- highline
- net-scp (>= 1.0.0)
- net-sftp (>= 2.0.0)
- net-ssh (>= 2.0.14)
- net-ssh-gateway (>= 1.1.0)
- coffee-rails (3.1.1)
+ coffee-rails (3.2.2)
coffee-script (>= 2.2.0)
- railties (~> 3.1.0)
+ railties (~> 3.2.0)
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.1.3)
- daemons (1.0.10)
+ coffee-script-source (1.2.0)
erubis (2.7.0)
- execjs (1.2.9)
+ execjs (1.3.0)
multi_json (~> 1.0)
- friendly_id (4.0.0.beta14)
- gem_plugin (0.2.3)
- highline (1.6.2)
+ friendly_id (4.0.0)
hike (1.2.1)
i18n (0.6.0)
- jquery-rails (1.0.17)
- railties (~> 3.0)
- thor (~> 0.14)
- json (1.6.1)
- kaminari (0.12.4)
- rails (>= 3.0.0)
- libv8 (3.3.10.2)
- mail (2.3.0)
+ journey (1.0.1)
+ json (1.6.5)
+ kaminari (0.13.0)
+ actionpack (>= 3.0.0)
+ activesupport (>= 3.0.0)
+ railties (>= 3.0.0)
+ libv8 (3.3.10.4)
+ mail (2.4.1)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
mime-types (1.17.2)
- mongrel (1.2.0.pre2)
- daemons (~> 1.0.10)
- gem_plugin (~> 0.2.3)
- multi_json (1.0.3)
- net-scp (1.0.4)
- net-ssh (>= 1.99.1)
- net-sftp (2.0.5)
- net-ssh (>= 2.0.9)
- net-ssh (2.2.1)
- net-ssh-gateway (1.1.0)
- net-ssh (>= 1.99.1)
- pg (0.11.0)
+ multi_json (1.0.4)
+ pg (0.13.1)
polyamorous (0.5.0)
activerecord (~> 3.0)
polyglot (0.3.3)
- rack (1.3.5)
+ rack (1.4.1)
rack-cache (1.1)
rack (>= 0.4)
- rack-mount (0.8.3)
- rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.1)
- actionmailer (= 3.1.1)
- actionpack (= 3.1.1)
- activerecord (= 3.1.1)
- activeresource (= 3.1.1)
- activesupport (= 3.1.1)
+ rails (3.2.1)
+ actionmailer (= 3.2.1)
+ actionpack (= 3.2.1)
+ activerecord (= 3.2.1)
+ activeresource (= 3.2.1)
+ activesupport (= 3.2.1)
bundler (~> 1.0)
- railties (= 3.1.1)
- railties (3.1.1)
- actionpack (= 3.1.1)
- activesupport (= 3.1.1)
+ railties (= 3.2.1)
+ railties (3.2.1)
+ actionpack (= 3.2.1)
+ activesupport (= 3.2.1)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2.2)
- ransack (0.5.8)
+ ransack (0.6.0)
actionpack (~> 3.0)
activerecord (~> 3.0)
polyamorous (~> 0.5.0)
- rdoc (3.11)
+ rdoc (3.12)
json (~> 1.4)
- sass (3.1.10)
- sass-rails (3.1.4)
- actionpack (~> 3.1.0)
- railties (~> 3.1.0)
- sass (>= 3.1.4)
- sprockets (~> 2.0.0)
+ sass (3.1.15)
+ sass-rails (3.2.4)
+ railties (~> 3.2.0)
+ sass (>= 3.1.10)
+ tilt (~> 1.3)
+ slim (1.1.0)
+ temple (~> 0.3.5)
tilt (~> 1.3.2)
- slim (1.0.3)
- temple (~> 0.3.4)
- tilt (~> 1.3.2)
- slim-rails (0.2.1)
- slim (>= 0.9.2)
- sprockets (2.0.3)
+ slim-rails (1.0.3)
+ actionpack (~> 3.0)
+ activesupport (~> 3.0)
+ railties (~> 3.0)
+ slim (~> 1.0)
+ sprockets (2.1.2)
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- sqlite3 (1.3.4)
- squeel (0.9.3)
+ sqlite3 (1.3.5)
+ squeel (0.9.5)
activerecord (~> 3.0)
activesupport (~> 3.0)
polyamorous (~> 0.5.0)
- temple (0.3.4)
- therubyracer (0.9.9)
+ temple (0.3.5)
+ therubyracer (0.9.10)
libv8 (~> 3.3.10)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- turn (0.8.3)
+ turn (0.9.3)
ansi
tzinfo (0.3.31)
- uglifier (1.0.4)
+ uglifier (1.2.3)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
@@ -162,22 +140,19 @@ PLATFORMS
DEPENDENCIES
ancestry
- capistrano
- coffee-rails (~> 3.1.1)
+ coffee-rails
execjs
friendly_id (~> 4.0.0.beta14)
- jquery-rails
json
kaminari
- mongrel (~> 1.2.0.pre2)
pg
- rails (~> 3.1.1)
+ rails (~> 3.2.0)
ransack
reusable_containers!
- sass-rails (~> 3.1.4)
+ sass-rails
slim-rails
- sqlite3 (= 1.3.4)
+ sqlite3
squeel
therubyracer
turn
- uglifier (>= 1.0.3)
+ uglifier
View
2  MIT-LICENSE
@@ -1,4 +1,4 @@
-Copyright 2011 YOURNAME
+Copyright 2011 Tosoa BACCA
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
View
3  lib/reusable_containers/version.rb
@@ -1,3 +0,0 @@
-module ReusableContainers
- VERSION = "0.0.1"
-end
View
8 reusable_containers.gemspec
@@ -1,22 +1,22 @@
$:.push File.expand_path("../lib", __FILE__)
# Maintain your gem's version:
-require "reusable_containers/version"
+require "./version"
# Describe your gem and declare its dependencies:
Gem::Specification.new do |s|
s.name = "reusable_containers"
s.version = ReusableContainers::VERSION
- s.authors = ["tosoa Bacca", "Mika Andrianarijaona"]
+ s.authors = ["Tosoa Bacca", "Mika Andrianarijaona"]
s.email = ["tosoa@jojopil.com", "mikaoelitiana@jojopil.com"]
s.homepage = "http://jojopil.com"
s.summary = "Reusable Containers Publication System"
s.description = "Yet another structured content publication system"
- s.files = Dir["{app,config,db,lib}/**/*"] + ["MIT-LICENSE", "Rakefile", "README.rdoc"]
+ s.files = Dir["{app,config,db,lib,script}/**/*"] + ["MIT-LICENSE", "Rakefile", "README.markdown", "version.rb", "TODO"]
s.test_files = Dir["test/**/*"]
- s.add_dependency "rails", "~> 3.1.1"
+ s.add_dependency "rails", "~> 3.2.1"
# s.add_dependency "jquery-rails"
s.add_development_dependency "sqlite3"
View
4 version.rb
@@ -1 +1,3 @@
-VERSION="0.0.1"
+module ReusableContainers
+ VERSION="0.0.1"
+end
Please sign in to comment.
Something went wrong with that request. Please try again.