Making flymake work with PHP CodeSniffer
Emacs Lisp
Switch branches/tags
Nothing to show
Pull request Compare This branch is even with senda-akiha:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
.gitignore
README.md
flymake-phpcs.el

README.md

Note

I recommend that you use the flycheck.
Because, you can run the checker more than one. Of course, including phpcs.

flymake-phpcs.el

PHP CodeSniffer for Emacs with flymake-mode.

To use PHP CodeSniffer with Emacs, you will need PHP CodeSniffer installed.

You should be able to run

$ phpcs

and, you'll also need to install flymake-easy.

Usage

You'll need to add the directory containing flymake-phpcs.el to your load-path.

If not, also add to your config

(add-to-list 'load-path "~/.emacs.d/path/to/flymake-phpcs.el")

Add to your Emacs config

(require 'flymake-phpcs)
(add-hook 'php-mode-hook 'flymake-phpcs-load)

How to customize the Coding Standard

(custom-set-variables
 '(flymake-phpcs-standard "PSR2"))

or

(custom-set-variables
 '(flymake-phpcs-standard "/path/to/MyStandard"))

phpcs command location

By default, the location of the phpcs command is searched.

(custom-set-variables
 '(flymake-phpcs-command "/path/to/phpcs"))

Where to create temporary copy

one of 'tempdir or 'inplace (default).

(custom-set-variables
 '(flymake-phpcs-location 'tempdir))