Permalink
Browse files

releases v1.3.0

  • Loading branch information...
1 parent 7c151b6 commit db531e57cbeae7eec0c14a7efe130a2fb7148ce5 @bmabey bmabey committed Apr 8, 2012
View
@@ -1,14 +1,11 @@
source 'http://gemcutter.org'
-
+#TODO: move these all over to the gemspec (via the Rakefile, except for maybe jeweler?)
gem "rake", ">= 0.8.7"
gem "jeweler"
gem "cucumber"
gem "cucumber-rails"
gem "cucumber-sinatra"
-gem "rspec", ">= 2.0.1"
gem "rspec-rails", ">= 2.0.1"
-gem "growl-glue", :require => "growl_glue"
-gem "autotest"
gem 'delayed_job', '~> 2.0'
gem "mimetype-fu", :require=> 'mimetype_fu'
gem "pony"
@@ -20,8 +17,9 @@ gem 'sqlite3-ruby', :require=>'sqlite3'
#gem 'email_spec', :path => '.'
gem 'capybara'
gem 'database_cleaner'
-gem 'launchy'
gem "test-unit"
+
+
gemspec
View
@@ -1,10 +1,31 @@
PATH
remote: .
specs:
- gardelea-email_spec (1.2.2)
- launchy (~> 2.0)
+ email_spec (1.3.0)
+ autotest
+ capybara
+ cucumber
+ cucumber-rails
+ cucumber-sinatra
+ database_cleaner
+ delayed_job (~> 2.0)
+ email_spec
+ growl-glue
+ jeweler
+ launchy
+ mail
mail (~> 2.2)
+ mimetype-fu
+ pony
+ rack-test
+ rails (= 3.0.7)
+ rake (>= 0.8.7)
+ rspec (>= 2.0.1)
rspec (~> 2.0)
+ rspec-rails (>= 2.0.1)
+ sinatra
+ sqlite3-ruby
+ test-unit
GEM
remote: http://gemcutter.org/
@@ -164,24 +185,20 @@ PLATFORMS
ruby
DEPENDENCIES
- autotest
capybara
cucumber
cucumber-rails
cucumber-sinatra
database_cleaner
delayed_job (~> 2.0)
- gardelea-email_spec!
- growl-glue
+ email_spec!
jeweler
- launchy
mail
mimetype-fu
pony
rack-test
rails (= 3.0.7)
rake (>= 0.8.7)
- rspec (>= 2.0.1)
rspec-rails (>= 2.0.1)
sinatra
sqlite3-ruby
View
@@ -1,4 +1,15 @@
-== 1.2.x (git)
+== 1.3.x (git)
+
+== 1.3.0 2011-04-07
+
+Many thanks to Derek Hammer and George Ardeleanu who both spontaneously cleaned up various parts of the project
+and helped get the release out the door. Yay opensoruce!
+
+ === New features
+ * Launchy is now used to open up the email viewer. (Matt Burke)
+ * Email Viewer now works in Rails 3 (Woody Peterson)
+ * Email Viewer now works with UTF-8. (Woody Peterson)
+ * Documentation for email matchers. (Derek Hammer)
== 1.2.1 2011-06-20
View
@@ -22,6 +22,7 @@ begin
s.has_rdoc = true
s.extra_rdoc_files = %w(README.rdoc MIT-LICENSE.txt)
s.rubyforge_project = 'email-spec'
+ s.add_runtime_dependency "launchy", "~> 2.1"
s.add_runtime_dependency "mail", "~> 2.2"
s.add_runtime_dependency "rspec", "~> 2.0"
end
View
@@ -1,5 +1,5 @@
---
-:patch: 2
+:patch: 0
:build:
:major: 1
-:minor: 2
+:minor: 3
View

Large diffs are not rendered by default.

Oops, something went wrong.
@@ -13,5 +13,5 @@ group :test do
gem 'capybara'
gem "rspec", ">= 2.0.1"
gem "rspec-rails", ">= 2.0.1"
- gem "gardelea-email_spec", :path => "../../", :require => "email_spec"
+ gem "email_spec", :path => "../../", :require => "email_spec"
end
@@ -1,14 +1,36 @@
PATH
remote: ../../
specs:
- gardelea-email_spec (1.2.2)
- launchy (~> 2.0)
+ email_spec (1.3.0)
+ autotest
+ capybara
+ cucumber
+ cucumber-rails
+ cucumber-sinatra
+ database_cleaner
+ delayed_job (~> 2.0)
+ email_spec
+ growl-glue
+ jeweler
+ launchy
+ mail
mail (~> 2.2)
+ mimetype-fu
+ pony
+ rack-test
+ rails (= 3.0.7)
+ rake (>= 0.8.7)
+ rspec (>= 2.0.1)
rspec (~> 2.0)
+ rspec-rails (>= 2.0.1)
+ sinatra
+ sqlite3-ruby
+ test-unit
GEM
remote: http://gemcutter.org/
specs:
+ ZenTest (4.7.0)
abstract (1.0.0)
actionmailer (3.0.7)
actionpack (= 3.0.7)
@@ -38,6 +60,8 @@ GEM
activesupport (3.0.7)
addressable (2.2.7)
arel (2.0.10)
+ autotest (4.4.6)
+ ZenTest (>= 4.4.1)
builder (2.1.2)
capybara (1.1.2)
mime-types (>= 1.16)
@@ -58,6 +82,8 @@ GEM
capybara (>= 1.1.2)
cucumber (>= 1.1.8)
nokogiri (>= 1.5.0)
+ cucumber-sinatra (0.5.0)
+ templater (>= 1.0.0)
daemons (1.1.8)
database_cleaner (0.7.2)
delayed_job (2.1.4)
@@ -66,10 +92,19 @@ GEM
diff-lcs (1.1.3)
erubis (2.6.6)
abstract (>= 1.0.0)
+ extlib (0.9.15)
ffi (1.0.11)
gherkin (2.9.3)
json (>= 1.4.6)
+ git (1.2.5)
+ growl-glue (1.0.7)
+ highline (1.6.11)
i18n (0.5.0)
+ jeweler (1.8.3)
+ bundler (~> 1.0)
+ git (>= 1.2.5)
+ rake
+ rdoc
json (1.6.6)
launchy (2.1.0)
addressable (~> 2.2.6)
@@ -83,6 +118,8 @@ GEM
multi_json (1.2.0)
nokogiri (1.5.2)
polyglot (0.3.3)
+ pony (1.4)
+ mail (> 2.0)
rack (1.2.5)
rack-mount (0.6.14)
rack (>= 1.0.0)
@@ -102,6 +139,8 @@ GEM
rake (>= 0.8.7)
thor (~> 0.14.4)
rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
rspec (2.9.0)
rspec-core (~> 2.9.0)
rspec-expectations (~> 2.9.0)
@@ -121,12 +160,20 @@ GEM
ffi (~> 1.0)
multi_json (~> 1.0)
rubyzip
+ sinatra (1.2.8)
+ rack (~> 1.1)
+ tilt (>= 1.2.2, < 2.0)
sqlite3 (1.3.5)
sqlite3-ruby (1.3.3)
sqlite3 (>= 1.3.3)
+ templater (1.0.0)
+ diff-lcs (>= 1.1.2)
+ extlib (>= 0.9.5)
+ highline (>= 1.4.0)
term-ansicolor (1.0.7)
test-unit (2.4.8)
thor (0.14.6)
+ tilt (1.3.3)
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
@@ -142,7 +189,7 @@ DEPENDENCIES
cucumber-rails
database_cleaner
delayed_job (~> 2.0)
- gardelea-email_spec!
+ email_spec!
mimetype-fu
rails (= 3.0.7)
rspec (>= 2.0.1)
Oops, something went wrong.

0 comments on commit db531e5

Please sign in to comment.