Skip to content

@dev-embedthis dev-embedthis released this Dec 21, 2018 · 20 commits to master since this release

Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Fix HTTP/2 protocol
  • Fix building without HTTP/2
  • Fix loading combined app modules
  • Cleanup MprModule in ESP callbacks
  • Reinstate httpTrace to have a HttpConn / HttpStream first parameter
  • Enable compat mode by default to map legacy APIs and structs (e.g. HttpConn -> HttpStream)

Build Requirements

  • To build, requires MakeMe 1.0 or later
  • To install paks, use Pak 1.0 or later

References:

Assets 2

@dev-embedthis dev-embedthis released this Dec 21, 2018 · 28 commits to master since this release

Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Fix parsing empty objects in JSON

Build Requirements

  • To build, requires MakeMe 1.0 or later
  • To install paks, use Pak 1.0 or later

References:

Assets 2

@mobsense mobsense released this Dec 14, 2018 · 38 commits to master since this release

Major Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Support HTTP/2 protocol

Build Requirements

  • To build, requires MakeMe 1.0 or later
  • To install paks, use Pak 1.0 or later

References:

Assets 2
Dec 3, 2018
Nov 30, 2018

@mobsense mobsense released this Apr 17, 2018 · 52 commits to master since this release

Minor Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Upgrade to match new Pak release (0.12.4) and using pak.json instead of package.json

Build Requirements

  • To build, requires MakeMe 0.10.8 or later
  • To install paks, use Pak 0.12.4 or later

References:

Assets 2

@mobsense mobsense released this Sep 28, 2017 · 86 commits to master since this release

Minor Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Remove more deprecated code
  • VS 2017 build fixes

Build Requirements

  • To build, requires MakeMe 0.10.7 or later
  • To install paks, use Pak 0.12.4 or later

References:

Assets 2

@mobsense mobsense released this Sep 28, 2017 · 88 commits to master since this release

Major Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Remove deprecated code
  • Support VS 2017

Build Requirements

  • To build, requires MakeMe 0.10.7 or later
  • To install paks, use Pak 0.12.4 or later

References:

Assets 2
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.