Skip to content

@dev-embedthis dev-embedthis released this Dec 14, 2018 · 47 commits to master since this release

Minor Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Support both OpenSSL 1.0 and 1.1 streams
  • Improve windows building
  • Support VS 2017 professional and community editions
  • Fix multiple response cookies

Build Requirements

  • To build, requires MakeMe 1.0 or later
  • To install packages, use Pak 1.0 or later

See

Assets 2

@mobsense mobsense released this Apr 17, 2018 · 70 commits to master since this release

Minor Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • [ ] Optional Upgrade -- Upgrade only if convenient

Change Log

  • Upgrade to match new Pak release (0.12.4) and using pak.json instead of package.json
  • Update for OpenSSL 1.1.0 and Mbedtls 2.8.0
  • Update for Alpine linux

Build Requirements

  • To build, requires MakeMe 0.10.8 or later
  • To install packages, use Pak 0.12.4 or later

See

Assets 2

@mobsense mobsense released this Feb 13, 2018 · 91 commits to master since this release

Security Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • [ ] Recommended Upgrade -- Upgrade recommended but not essential
  • [ ] Optional Upgrade -- Upgrade only if convenient

Change Log

  • Fix denial of service #264

Build Requirements

  • To build, requires MakeMe 0.10.6 or later
  • To install packages, use Pak 0.12.2 or later

See

Assets 2

@mobsense mobsense released this Sep 22, 2017 · 116 commits to master since this release

Major Release

Recommended Action

  • [ ] Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • [ ] Optional Upgrade -- Upgrade only if convenient

Change Log

  • Remove deprecated APIs
  • Strengthen read-only API parameters by changing "char*" to "const char*"
  • Add limit for number of CGI args
  • Fix upload requests missing the "name" field that caused a DoS for malformed requests
  • Fix invalid memory reference upload handler
  • Support Visual Studio 2017
  • Documentation updates

Build Requirements

  • To build, requires MakeMe 0.10.6 or later
  • To install packages, use Pak 0.12.2 or later

See

Assets 2

@mobsense mobsense released this Jun 9, 2017 · 161 commits to master since this release

Important Security Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Fix remote code injection into dynamically linked CGI programs on Linux
  • Fix crash when pruning sessions that have been recreated
  • Add CGI variable prefix cgiVarPrefix in main.me
  • Fix memory leak with SSL load test

Build Requirements

  • To build, requires MakeMe 0.10.4 or later
  • To install packages, use Pak 0.12.1 or later

See

Assets 2

@embedthis embedthis released this Jun 9, 2017 · 168 commits to master since this release

Minor Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Support new build farm
  • Fix memory leak in websCryptPassword, websCheckPassword
  • Fix websRunEvents delay calculation
  • Fix memory leak in websProcessUplaodData
  • Doc updates

Build Requirements

  • To build, requires MakeMe 0.10.4 or later
  • To install packages, use Pak 0.12.1 or later

See

Assets 2

@embedthis embedthis released this Jun 2, 2016 · 191 commits to master since this release

Minor Patch Release

Recommended Action

  • Essential Upgrade -- All users strongly advised to upgrade
  • Recommended Upgrade -- Upgrade recommended but not essential
  • Optional Upgrade -- Upgrade only if convenient

Change Log

  • Upgrade to mbedtls 2.2.1
  • Fix importing openssl libraries when building
  • Add openssl renegotiation controls via main.me: ssl.handshakes
  • Fix missing va_end in jsArgs
  • Add missing initializer to websRomIndex
  • Improve BPUT macros
  • Add websSetLogLevel and snclone APIs
  • Add issue template
  • Fix busy wait on socket disconnect
  • Fix handling negative timezones and offsets
  • Add VxWorks 7 support
  • Fix cross compiling sleuthing the cross compiler options
  • Fix using --set compiler.has* configuration options
  • Added fortification to compiler options and ASLR

Build Requirements

  • To build, requires MakeMe 0.10.4 or later
  • To install packages, use Pak 0.12.1 or later

See

Assets 2
You can’t perform that action at this time.