Skip to content
No description, website, or topics provided.
Branch: master
Clone or download
Type Name Latest commit message Commit time
Failed to load latest commit information.
addon fix: support engine resolution in scoped packages Feb 15, 2019
config upgrade CLI Jul 21, 2018
.github_changelog_generator Update CHANGELOG file Aug 15, 2016
.gitignore upgrade CLI Jul 21, 2018
.npmignore upgrade CLI Jul 21, 2018
.travis.yml upgrade CLI Jul 21, 2018
LICENSE Update `ember-cli` to `2.8.0` Sep 28, 2016
ember-cli-build.js Use build-time `project.isModuleUnification()` instead of feature flag. Mar 14, 2018
package.json Bump eslint-plugin-ember from 6.2.0 to 6.3.0 Mar 20, 2019
testem.js upgrade CLI Jul 21, 2018

Ember Resolver Build Status

This project provides the Ember resolver used by the following projects:


ember-resolver is an ember-cli addon, and should be installed with ember install:

ember install ember-resolver


To customize pluralization provide a pluralizedTypes object to your extended version of the Resolver in consuming app:

# app/resolver.js
import Resolver from 'ember-resolver';

export default Resolver.extend({
  pluralizedTypes: {
    'sheep': 'sheep',
    'strategy': 'strategies'


ember-resolver is normally bumped with ember-cli releases. To install a newer version use yarn or npm. For example:

yarn upgrade ember-resolver

Migrating from bower

Before v1.0.1 ember-resolver was primarially consumed via bower. To migrate install the addon version via yarn or npm. If you're currently using ember-resolver v0.1.x in your project, you should uninstall it:

bower uninstall ember-resolver --save

You can continue to use ember-resolver v0.1.x as a bower package, but be careful not to update it to versions greater than v1.0.

Addon Development


  • git clone this repository
  • npm install
  • bower install


Running Tests

  • ember test
  • ember test --server


  • ember build

For more information on using ember-cli, visit


As mentioned above, ember-resolver is no longer a bower package. If you're seeing a message like this:

Unable to find a suitable version for ember-resolver, please choose one:
    1) ember-resolver#~0.1.20 which resolved to 0.1.21 and is required by ember-resolver#2.0.3
    2) ember-resolver#~2.0.3 which resolved to 2.0.3 and is required by [APP_NAME]

... you probably need to update your application accordingly. See aptible/ as an example of how to update.

You can’t perform that action at this time.