Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Barber extraction broke config.ember.ember_location #103

Closed
SamSaffron opened this Issue Nov 21, 2012 · 1 comment

Comments

Projects
None yet
3 participants

This relates both to ember-rails and barber,

Barber needs a way to specify both ember and handlebar locations, ember-rails needs a way to support custom handlebar and ember locations, both for normal usage and for precompiles.

At the moment config.ember.ember_location is broken.

Owner

machty commented Feb 27, 2013

The way this works now is we use the ember-source / handlebars-source wrapper gems to select which versions of ember/handlebars to use. If you still needed to specify a custom version of handlebars / ember rather than the ones bundled in those gems, you'd have to override the bundled_path functions provided in those gems, see here and here.

Let us know if you still can't do what you're trying to do, but the move toward lightweight wrapper gems should pretty much solve these types of problems.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment