0.11.* branch dependency conflict #168

Closed
heartsentwined opened this Issue Mar 30, 2013 · 7 comments

Comments

Projects
None yet
7 participants

#0.11.0

Gemfile:

source 'https://rubygems.org'
gem 'ember-rails', '0.11.0'

Error:

Fetching gem metadata from https://rubygems.org/...........
Resolving dependencies...
Bundler could not find compatible versions for gem "handlebars-source":
  In Gemfile:
    ember-rails (= 0.11.0) ruby depends on
      handlebars-source (< 1.0.0.rc4, >= 1.0.0.rc3) ruby

    ember-rails (= 0.11.0) ruby depends on
      handlebars-source (1.0.0)

#0.11.1

Gemfile:

source 'https://rubygems.org'
gem 'ember-rails', '0.11.1'

Error:

Fetching gem metadata from https://rubygems.org/...........
Resolving dependencies...
Bundler could not find compatible versions for gem "handlebars-source":
  In Gemfile:
    ember-rails (= 0.11.1) ruby depends on
      handlebars-source (< 1.0.0.rc4, >= 1.0.0.rc3) ruby

    ember-rails (= 0.11.1) ruby depends on
      handlebars-source (1.0.0)

0.10.0 does not have this error and installs smoothly.

Adding an explicit handlebars-source line solves the problem, thus:
Gemfile:

source 'https://rubygems.org'
gem 'ember-rails', '~> 0.11'
gem 'handlebars-source', '1.0.0.rc3'

However, if ember-rails explicitly requires a RC version of handlebars-source, and if bundler will not install RC's by default, then perhaps we should put an explicity gem dependency of handlebars-source at 1.0.0rc3 into the gemspec itself?

vladiim commented Mar 31, 2013

+1

jcc2303 commented Apr 1, 2013

+1

ootoovak commented Apr 5, 2013

Duplicate issue I think: #165

joscas commented Apr 7, 2013

+1

cyril-sf added a commit to cyril-sf/ember-rails that referenced this issue Apr 28, 2013

cyril-sf added a commit to cyril-sf/ember-rails that referenced this issue Apr 28, 2013

cyril-sf added a commit to cyril-sf/ember-rails that referenced this issue Apr 28, 2013

lukemelia added a commit to yappbox/ember-rails that referenced this issue Apr 28, 2013

Test against latest Ember RC2 and RC3 gems, and Rails 3.1, 3.2 and 4,…
… and specify gem dependencies accordingly.

[Fixes #165 #168]
Owner

stefanpenner commented May 24, 2013

the readme hopes to help with this: https://github.com/emberjs/ember-rails

once we get out of rc's we should be out of this mess.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment