Skip to content

Should ship with fixed dependencies. #92

meskyanichi opened this Issue Sep 3, 2012 · 1 comment

2 participants


I'm trying Ember Rails and it seems that when I try to load in Ember itself it complains about JQuery (in jquery-rails) being version 1.8 rather than 1.7. So, had to look up a more recent version of jquery-rails (version = 2.0.3) which fixed that issue. Next issue is that it was complaining about handlebars (which it ships with the gem?) saying that it has to be version >= 1.0.5.beta (or something). So there were basically 2 dependency JS dependency issue going on and it took some time to figure out which version of jquery-rails was necessary, and I just got the most recent handlebars.js from the official site and dropped it in my vendor. I thought of just removing the gem but it appears that it's still useful for handlebars in the asset pipeline.

Maybe I'm doing something wrong, but I simply tried using the latest gem (and then the repositories HEAD) on a bare Rails app but couldn't get it to work without manually dropping in specific versions of jQuery and Handlebars.js.

If Ember.js is going to complain about specific jQuery versions, maybe it's useful, since Rails always ships with jquery-rails, to add the jquery-rails, = 2.0.3 to the dependency list? This would then use jQuery 1.7.x from what I can see. Also, I guess for Handlebars.js, just drop in the latest version of it to replace whatever version is currently being used.

Ember.js member
tchak commented Oct 27, 2012

We bumped ember to latest version...

@tchak tchak closed this Oct 27, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.