Permalink
Browse files

Support jQuery 1.8 - fixes #1267

  • Loading branch information...
1 parent 1add8c1 commit 35fb8026e6f5abbeb936cd98f17e749f257beef1 @wagenet wagenet committed Aug 14, 2012
Showing with 4 additions and 3 deletions.
  1. +2 −1 Rakefile
  2. +1 −1 packages/ember-views/lib/core.js
  3. +1 −1 tests/index.html
View
@@ -137,7 +137,8 @@ task :test, [:suite] => :dist do |t, args|
:default => packages.map{|p| "package=#{p}" },
:runtime => [ "package=ember-metal,ember-runtime" ],
:all => packages.map{|p| "package=#{p}" } +
- ["package=all&jquery=git&nojshint=true",
+ ["package=all&jquery=1.7.2&nojshint=true",
+ "package=all&jquery=git&nojshint=true",
"package=all&extendprototypes=true&nojshint=true",
"package=all&extendprototypes=true&jquery=git&nojshint=true",
"package=all&nocpdefaultcacheable=true&nojshint=true",
@@ -5,5 +5,5 @@
// License: Licensed under MIT license (see license.js)
// ==========================================================================
-Ember.assert("Ember Views require jQuery 1.7", window.jQuery && (window.jQuery().jquery.match(/^1\.7(\.\d+)?(pre|rc\d?)?/) || Ember.ENV.FORCE_JQUERY));
+Ember.assert("Ember Views require jQuery 1.7 or 1.8", window.jQuery && (window.jQuery().jquery.match(/^1\.[78](\.\d+)?(pre|rc\d?)?/) || Ember.ENV.FORCE_JQUERY));
Ember.$ = window.jQuery;
View
@@ -104,7 +104,7 @@ <h2 id="qunit-userAgent"></h2>
<script>
// Load custom version of jQuery if possible
- var jQueryVersion = QUnit.urlParams.jquery || "1.7.2";
+ var jQueryVersion = QUnit.urlParams.jquery || "1.8.0";
if (jQueryVersion !== 'none') {
document.write('<script src="http://code.jquery.com/jquery-'+jQueryVersion+'.js"><\/script>');
}

0 comments on commit 35fb802

Please sign in to comment.