Skip to content
Browse files

bumped jQuery to 1.7.2+, explicitly forbidding 1.7 and 1.7.1 (see: #1448

)

regex does not match:

* 1.7
* 1.7.0
* 1.7.1

regex matches:

* 1.7.2
* 1.8.0
* 1.8.1
* 1.8.2
* 1.8.3pre
* 1.8.4rc4
  • Loading branch information...
1 parent 6cff4b2 commit 5883f63df4dfe3cc4e1f58805dc3dd98d7ef9a22 @george george committed
Showing with 3,576 additions and 3,540 deletions.
  1. +3,575 −3,539 lib/{jquery-1.7.2.js → jquery-1.8.2.js}
  2. +1 −1 packages/ember-views/lib/core.js
View
7,114 lib/jquery-1.7.2.js → lib/jquery-1.8.2.js
3,575 additions, 3,539 deletions not shown because the diff is too large. Please use a local Git client to view these changes.
View
2 packages/ember-views/lib/core.js
@@ -4,7 +4,7 @@
*/
var jQuery = Ember.imports.jQuery;
-Ember.assert("Ember Views require jQuery 1.7 or 1.8", jQuery && (jQuery().jquery.match(/^1\.[78](\.\d+)?(pre|rc\d?)?/) || Ember.ENV.FORCE_JQUERY));
+Ember.assert("Ember Views require jQuery 1.7 or 1.8", jQuery && (jQuery().jquery.match(/^1\.(7(?!$)(?!\.[01])|8)(\.\d+)?(pre|rc\d?)?/) || Ember.ENV.FORCE_JQUERY));
/**
Alias for jQuery

0 comments on commit 5883f63

Please sign in to comment.
Something went wrong with that request. Please try again.