New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

display() broken with python3 #126

Closed
changwoo opened this Issue Jul 17, 2013 · 1 comment

Comments

2 participants
@changwoo

changwoo commented Jul 17, 2013

$ cat wtest.py
from wand.image import Image
from wand.display import display
with Image(filename='a.jpg') as img:
    print(img.size)
    for r in 1, 2, 3:
        with img.clone() as i:
            i.resize(int(i.width * r * 0.25), int(i.height * r * 0.25))
            i.rotate(90 * r)
            i.save(filename='a-{0}.jpg'.format(r))
            display(i)
$ python3 wtest.py
(80, 86)
Traceback (most recent call last):
  File "wtest.py", line 11, in 
    display(i)
  File "/usr/lib/python3/dist-packages/wand/display.py", line 66, in display
    library.MagickDisplayImage(image.wand, str(server_name))
ctypes.ArgumentError: argument 2: : wrong type
$

@ghost ghost assigned dahlia Jul 17, 2013

dahlia added a commit that referenced this issue Jul 17, 2013

@dahlia dahlia closed this in 1be76b8 Aug 4, 2013

@dahlia

This comment has been minimized.

Collaborator

dahlia commented Aug 4, 2013

This is included in the 0.3.3 release. 🍰

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment