0.2.10 once never finishes #167

Closed
antoineB opened this Issue Dec 19, 2012 · 4 comments

Comments

Projects
None yet
3 participants

When i run "lein cljsbuild once", it never gives me back bash prompt.

Leiningen 2.0.0-preview10 on Java 1.6.0_18 OpenJDK Client VM

(defproject essai "0.1.0-SNAPSHOT"
:description "FIXME: write description"
:url "http://example.com/FIXME"
:license {:name "Eclipse Public License"
:url "http://www.eclipse.org/legal/epl-v10.html"}
:source-paths ["src-clj"]
:plugins [[lein-cljsbuild "0.2.10"]]
:cljsbuild {
:builds [{
; The path to the top-level ClojureScript source directory:
:source-path "src"
; The standard ClojureScript compiler options:
; (See the ClojureScript compiler documentation for details.)
:compiler {
;:output-to "war/javascripts/main.js" ; default: main.js in current directory
:optimizations :whitespace
:pretty-print true}}]})

Owner

emezeske commented Dec 19, 2012

Would you mind trying lein cljsbuild once in the simple and advanced example projects to see whether you get the same result with them? I'm not able to reproduce this locally, but if you can show that the problem shows up with the example projects, I at least have a good place to start.

An example that doesn't work : https://github.com/antoineB/cljsbuild-once-example

I do a test with the simple example (i change the lein-cljsbuild from 0.2.9 to 0.2.10) and i got the same problem.

Owner

emezeske commented Jan 21, 2013

Maybe related to #171?

This might be related to http://dev.clojure.org/jira/browse/CLJS-430, but this was resolved in the most recent CLJS release.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment