Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Changed the gem deps to use the ~> instead of >=

  • Loading branch information...
commit f6b4f6b216073e65fe8dd6b868087038b415be66 1 parent 4070104
Dan Kubb authored
View
2  Rakefile
@@ -13,7 +13,7 @@ AUTHOR = "Sam Smoot"
EMAIL = "ssmoot@gmail.com"
GEM_NAME = "dm-core"
GEM_VERSION = DataMapper::VERSION
-GEM_DEPENDENCIES = ["data_objects", ">=0.9.7"], ["extlib", ">=0.9.8"],
+GEM_DEPENDENCIES = ["data_objects", "~>0.9.7"], ["extlib", "~>0.9.8"],
["rspec", ">=1.1.3"], ["addressable", "~>2.0"]
View
12 dm-core.gemspec
@@ -22,19 +22,19 @@ Gem::Specification.new do |s|
s.specification_version = 2
if current_version >= 3 then
- s.add_runtime_dependency(%q<data_objects>, [">= 0.9.7"])
- s.add_runtime_dependency(%q<extlib>, [">= 0.9.8"])
+ s.add_runtime_dependency(%q<data_objects>, ["~> 0.9.7"])
+ s.add_runtime_dependency(%q<extlib>, ["~> 0.9.8"])
s.add_runtime_dependency(%q<rspec>, [">= 1.1.3"])
s.add_runtime_dependency(%q<addressable>, ["~> 2.0"])
else
- s.add_dependency(%q<data_objects>, [">= 0.9.7"])
- s.add_dependency(%q<extlib>, [">= 0.9.8"])
+ s.add_dependency(%q<data_objects>, ["~> 0.9.7"])
+ s.add_dependency(%q<extlib>, ["~> 0.9.8"])
s.add_dependency(%q<rspec>, [">= 1.1.3"])
s.add_dependency(%q<addressable>, ["~> 2.0"])
end
else
- s.add_dependency(%q<data_objects>, [">= 0.9.7"])
- s.add_dependency(%q<extlib>, [">= 0.9.8"])
+ s.add_dependency(%q<data_objects>, ["~> 0.9.7"])
+ s.add_dependency(%q<extlib>, ["~> 0.9.8"])
s.add_dependency(%q<rspec>, [">= 1.1.3"])
s.add_dependency(%q<addressable>, ["~> 2.0"])
end
View
2  lib/dm-core.rb
@@ -20,7 +20,7 @@
gem 'addressable', '~>2.0'
require 'addressable/uri'
-gem 'extlib', '>=0.9.8'
+gem 'extlib', '~>0.9.8'
require 'extlib'
require "extlib/inflection"
View
2  lib/dm-core/adapters/data_objects_adapter.rb
@@ -1,4 +1,4 @@
-gem 'data_objects', '>=0.9.7'
+gem 'data_objects', '~>0.9.7'
require 'data_objects'
module DataMapper
View
2  lib/dm-core/adapters/mysql_adapter.rb
@@ -1,4 +1,4 @@
-gem 'do_mysql', '>=0.9.7'
+gem 'do_mysql', '~>0.9.7'
require 'do_mysql'
module DataMapper
View
2  lib/dm-core/adapters/postgres_adapter.rb
@@ -1,4 +1,4 @@
-gem 'do_postgres', '>=0.9.7'
+gem 'do_postgres', '~>0.9.7'
require 'do_postgres'
module DataMapper
View
2  lib/dm-core/adapters/sqlite3_adapter.rb
@@ -1,4 +1,4 @@
-gem 'do_sqlite3', '>=0.9.7'
+gem 'do_sqlite3', '~>0.9.7'
require 'do_sqlite3'
module DataMapper
Please sign in to comment.
Something went wrong with that request. Please try again.