Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

python script plugin did not accept the script #12

Closed
cedenoaugusto opened this issue Jul 22, 2014 · 33 comments

Comments

@cedenoaugusto
Copy link

@cedenoaugusto cedenoaugusto commented Jul 22, 2014

I got the exception when I pressed: ctrl+alt+enter "python script plugin did not accept the script"

What can I do?

@cedenoaugusto

This comment has been minimized.

Copy link
Author

@cedenoaugusto cedenoaugusto commented Jul 22, 2014

Version notepad++ 6.6.7

@brendena

This comment has been minimized.

Copy link

@brendena brendena commented Jul 29, 2014

some problem also running notepad++ 6.6.7

@mmosoll

This comment has been minimized.

Copy link

@mmosoll mmosoll commented Sep 30, 2014

Replace Notepad++ Python package with PythonScript_full_0.9.2.0.7z and unpack all archives in Notepad++ main directory. I am using notepad++ v6.6.9.

http://sourceforge.net/projects/npppythonscript/files/Python%20Script%200.9.2.0/

Check also your Shortcut Mapper if necessary

@savvinovan

This comment has been minimized.

Copy link

@savvinovan savvinovan commented Oct 7, 2014

i have same problem, but mmosoll method helps, thank you. Is emmet work in notepad++ with lag? Around 0.5-1second? In sublime emmet works instantly, but in notepad++ it works with lag

@geandre

This comment has been minimized.

Copy link

@geandre geandre commented Jan 26, 2015

Thank you mmosoll, running on Notepad++ Je Suis Charlie Edition...

@jerweb63

This comment has been minimized.

Copy link

@jerweb63 jerweb63 commented Mar 11, 2015

Helped me out. Thanks mmosoll!

@TanmayDharmaraj

This comment has been minimized.

Copy link

@TanmayDharmaraj TanmayDharmaraj commented Mar 13, 2015

Worked for me. thanks a lot

@superadministrator

This comment has been minimized.

Copy link

@superadministrator superadministrator commented Mar 31, 2015

Thank you mmosoll, I tried your solution, it worked for me!

@ghost

This comment has been minimized.

Copy link

@ghost ghost commented May 12, 2015

I settled this problem as follows:
1.Manual installation Emmet
Manual installation

Install Python Script plugin (available in Plugin Manager).
Download EmmetNPP plugin and unpack it into C:\Program Files\Notepad++\plugins folder
Start Nodepad++. You should see Plugins > Emmet menu item

2.Replace Notepad++ Python package with PythonScript_full_0.9.2.0.7z as mmosoll said before.

3.change the shortcut mapper Settings > setting-plugin commands --Expand abbreviation to tab

@cedenoaugusto

This comment has been minimized.

Copy link
Author

@cedenoaugusto cedenoaugusto commented May 14, 2015

I followed yours instruccions, but it does not work for me. Instead I have been using Brackets.

Wrote: "table>tr>td"

Then, in the Menu: Plugin > Emmet > Expand...

Produces:
Message1: Unknown exception
Message2: Phyton Script Plugin did not accept the script

Win 7
NP++ v6.7.5

@ghost

This comment has been minimized.

Copy link

@ghost ghost commented May 15, 2015

hi~~Augusto Cedeño

  1. make sure you Manual installation Emmet
    2.down load Python Script Plugin,http://sourceforge.net/projects/npppythonscript/files/Python%20Script%200.9.2.0/
    then replace Notepad++ Python
    image

2015-05-15

pplflymoon2013

发件人:Augusto Cedeño notifications@github.com
发送时间:2015-05-15 05:00
主题:Re: [npp] python script plugin did not accept the script (#12)
收件人:"emmetio/npp"npp@noreply.github.com
抄送:"pplflymoon"pplflymoon2013@gmail.com

I followed yours instruccions, but it does not work for me. Instead I have been using Brackets.
Wrote: "table>tr>td"
Then, in the Menu: Plugin > Emmet > Expand...
Produces:
Message1: Unknown exception
Message2: Phyton Script Plugin did not accept the script
Win 7
NP++ v6.7.5

Reply to this email directly or view it on GitHub.

@mmosoll

This comment has been minimized.

Copy link

@mmosoll mmosoll commented May 18, 2015

The "Phyton Script Plugin did not accept the script" error appeared with the old phyton scripts distributed with NP++.

The last Notepad++ v6.7.7 with Emmet plugin (last version is 1.0.2) is running fine (only time lag when expresion is too large). I updated NP++ but PythonScripts were updated (several version ago) with the PythonScript_full_0.9.2.0.7z archive:

http://sourceforge.net/projects/npppythonscript/files/Python%20Script%200.9.2.0/

Unpack PythonScript_full_0.9.2.0.7z in NP++ main directory and check also your Shortcut Mapper if necessary.

@wassem

This comment has been minimized.

Copy link

@wassem wassem commented Aug 25, 2015

hi
i have notepad++ version 6.8.2
Emmet plugin 1.0.0
python script 1.0.6.0
Python 2.7.6-notepad++ r2 (default, Apr 21 2014, 19:26:54) [MSC v.1600 32 bit (Intel)]

same problem
python script plugin did not accept the script

?

@mmosoll

This comment has been minimized.

Copy link

@mmosoll mmosoll commented Aug 26, 2015

I am using notepad++ v6.8.2
Emmet plugin 1.0.2 running fine with PythonScript_full_0.9.2.0.7z (see previous post)

@BugZappr

This comment has been minimized.

Copy link

@BugZappr BugZappr commented Sep 6, 2015

OK, so I inspected the 0.9.2.0 archive for PythonScript, and noticed that it contained \plugins\PythonScript\lib, \plugins\PythonScript\scripts and \docs directories that were not present in my installation in which Emmet was malfunctioning. Not content to do a needless downgrade, I simply dropped these folders into my Notepad++ dir. Emmet started working, even with the PythonScript installed through the plugin manager. Not being content with out of date scripts, I deleted the scripts and docs I had just dropped in, and dropped in the entire contents of the 1.0.8.0 plugin script folder. It appears to be running perfectly fine now; even picking up a custom snippets.json definition.

It appears that what is now needed to fix this plugin is not for someone to update the Emmet plugin to run with the new PythonScript, which appears to be fully compatible with the Emmet plugin, but that the additional folders and files in the downloadable PythonScript archives (I used "PythonScript_Full_1.0.8.0.zip") also be included in the Plugin Manager's installation (provided it can do it).

Hope this shortens someone's path, and helps ppl find the Zen of Emmet coding sooner.

@mmosoll

This comment has been minimized.

Copy link

@mmosoll mmosoll commented Sep 7, 2015

Very good job BugZappr,

Summarizing your work:
1 - From Notepad++ plugins directory

  • Remove PythonScript.dll
  • Remove PythonScript directory
  • Remove doc\PythonScript directory

2 - I used PythonScript from http://sourceforge.net/projects/npppythonscript/files/Python%20Script%201.0.8.0/PythonScript_Full_1.0.8.0.zip
and copy the following extracted files plugins\PythonScript.dll, plugins\doc, plugins\PythonScript\ to the Notepad++ plugins directory.

At first glance, I think with this update Emmet speed performance was increased :-)

Thank you

@lwd1900

This comment has been minimized.

Copy link

@lwd1900 lwd1900 commented Sep 9, 2015

hi
i have notepad++ version 6.8.2

Emmet plugin 1.0.0

python script 1.0.6.0

Emmet is no work..........

What can I do? Thanks in advance.

@BugZappr

This comment has been minimized.

Copy link

@BugZappr BugZappr commented Sep 11, 2015

lwd1900: Those are the precise versions I had. You will need to copy the contents of the above given archive into yer NPP dir; not just install it from the plugin manager. As this issue is closed, presumably the plugin manager's archive is being updated.

@mac10046

This comment has been minimized.

Copy link

@mac10046 mac10046 commented Nov 10, 2015

Thanx bro - I am using 6.8.6 version and your solution actually worked .... @mmosoll

@Mohammad-H

This comment has been minimized.

Copy link

@Mohammad-H Mohammad-H commented Apr 22, 2016

Thank you mmosoll

@Rafiozoo

This comment has been minimized.

Copy link

@Rafiozoo Rafiozoo commented Jun 22, 2016

Almost worked on my machine: only choosing from menu Emmet expanded or wrapped, because default shortcuts (Ctrl-Alt-Enter, Ctrl-Shift-Alt-Enter) are overridden. I didn't search for conflicts, just set new shortcuts (Ctrl-Shift-E for expanding, and Ctrl-Shift-A for wrapping work fine).

I've tried Emmet on Notepad++, Adobe Brackets and Sublime Text 3.
The best experience with Emmet: Sublime Text, and the worst: Notepad++.

@Kaderbhai

This comment has been minimized.

Copy link

@Kaderbhai Kaderbhai commented Jul 7, 2016

Thank you mmosoll

@nicolasfuentes

This comment has been minimized.

Copy link

@nicolasfuentes nicolasfuentes commented Jul 19, 2016

I can't believe, it's working!
thanks mmosoll and pplflymoon

@edgexie

This comment has been minimized.

Copy link

@edgexie edgexie commented Jul 21, 2016

I can't download the Python at the link that you provide,mmosoll. it's too slow . Wuuuu, I'm in china.

@cedenoaugusto

This comment has been minimized.

Copy link
Author

@cedenoaugusto cedenoaugusto commented Sep 1, 2016

Now it works.

After I downloaded and installed Python Script Plugin: http://sourceforge.net/projects/npppythonscript/files/Python%20Script%200.9.2.0/

Thanks pplflymoon and mmosoll.

@fzhw88

This comment has been minimized.

Copy link

@fzhw88 fzhw88 commented Dec 10, 2016

1.0.8.0 Python Script is OK,but you must installed the full vision by yourself not by plugin Manager

@BugZappr

This comment has been minimized.

Copy link

@BugZappr BugZappr commented Jan 9, 2017

I've installed it via plugin manager. I reported the problem with the libraries to the Python plugin guys. It now works if you just install it via the plugin manager.

@LaitonGarcia

This comment has been minimized.

Copy link

@LaitonGarcia LaitonGarcia commented Mar 1, 2017

Aqui funfou beleza mmosoll, Obrigado!

@ybhuxiao

This comment has been minimized.

Copy link

@ybhuxiao ybhuxiao commented Mar 20, 2017

Thank you mmosoll, worked for me!

@tgroff

This comment has been minimized.

Copy link

@tgroff tgroff commented Oct 27, 2017

yep, solution #12 (comment) still works, thanks!

@BugZappr

This comment has been minimized.

Copy link

@BugZappr BugZappr commented Oct 27, 2017

I'm glad it works now. You guys all seem to think the solution was given by mmosoll; but I was the one who first posted it for him to restate, FWIW! You can read it in the comments above for yourselves. Emmit now works when downloaded with PythonScript from the Plugin Manager; although NPP's Plugin Manager has an ad graphic, and they have quit using Plugin Manager by default. They will replace it with a banner-free version soon. You can still install Plugin Manager as an optional plug-in. I recently tested this on a PortableApps version starting from a clean install. NPP's PythonScript now downloads and installs Python's libraries too.

@R-14

This comment has been minimized.

Copy link

@R-14 R-14 commented Mar 1, 2018

Hello, when I installed emmet and notepad++ there were no pre-existing pythonscript.dll files. I went to the link that @BugZappr suggested and downloaded a file from there. I extracted the Pythonscript.dll files to C/ProgrammeFiles/Notepad++/Plugins. However when I open up Notepad++ and I try to install pythonscript via the plugin manager I continue to get an error message saying installation failed. Where am I going wrong? I can install Python Indent but not the script files...
2018-03-01

@R-14

This comment has been minimized.

Copy link

@R-14 R-14 commented Mar 1, 2018

Right, so I moved the pythonscript.dll files around and now I have this ...
python script

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
You can’t perform that action at this time.