Babel preset for all plugins needed with the latest electron
JavaScript
Permalink
Failed to load latest commit information.
LICENSE Initial 37.8 commit May 4, 2016
README.md Initial 37.8 commit May 4, 2016
index.js Remove unnecessary dependencies May 6, 2016
package.json Remove unnecessary dependencies May 6, 2016

README.md

babel-preset-electron

Babel preset with all plugins for Electron.

Install

Electron 37.8

$ npm install --save-dev babel-preset-electron@37.8

Usage

Via .babelrc (Recommended)

.babelrc

{
  "presets": ["electron"]
}

Via CLI

$ babel script.js --preset electron

Via Node API

require("babel-core").transform("code", {
  presets: ["electron"]
});