New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fail fast in case the otp version in use is 20 or older #217

Merged
merged 1 commit into from Sep 8, 2018

Conversation

Projects
None yet
3 participants
@spring2maz
Contributor

spring2maz commented Sep 2, 2018

Tried to build with otp 20, failed.
Then I figured that we probably have stopped supporting it.
This PR adds an assertion as all target's dependency to fail fast for otp earlier than 21.

@Gilbert-Wong Gilbert-Wong requested review from emqplus and Gilbert-Wong Sep 3, 2018

@terry-xiaoyu

This comment has been minimized.

Contributor

terry-xiaoyu commented Sep 8, 2018

nice 👍

@terry-xiaoyu terry-xiaoyu merged commit 774cfff into emqx30 Sep 8, 2018

@terry-xiaoyu terry-xiaoyu deleted the fail-fast-for-otp-20-or-older branch Sep 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment