Skip to content
No description, website, or topics provided.
TypeScript
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.vscode
src fix(scripts): start and build Dec 29, 2019
.eslintignore
.eslintrc
.gitignore
.prettierrc
README.md
docker-compose.yml
package.json
renovate.json
tsconfig.json
yarn.lock

README.md

Base para proyecto con Apollo y Typescript

Proyecto base para iniciar Apollo con Typescript

Require:

  • Docker >= v19.03.5
  • Node >= v10.16.3
  • Npm >= v6.12.0
  • Archivo .env

Ejecutar antes del proyecto:

docker-compose up

Archivo .env, ejemplo:

PORT=4000
POSTGRES_DB_DEV=postgres_db
POSTGRES_USER_DEV=admin_db
POSTGRES_PASSWORD_DEV=admin_12345678
POSTGRES_DB_PROD=A
POSTGRES_USER_PROD=A
POSTGRES_PASSWORD_PROD=A

Algunos comandos:

yarn          # Instala las dependencias
yarn develop  # Ejecuta el proyecto desde typescript, esperando cambios
yarn build    # Transpila el código de typescript a javascript
yarn start    # Transpila y ejecuta el proyecto
You can’t perform that action at this time.