Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problems rendering html in the new Live API #4952

Closed
6 tasks done
atkawa7 opened this issue Mar 9, 2017 · 4 comments
Closed
6 tasks done

Problems rendering html in the new Live API #4952

atkawa7 opened this issue Mar 9, 2017 · 4 comments
Labels
Milestone

Comments

@atkawa7
Copy link
Contributor

atkawa7 commented Mar 9, 2017

Checklist

  • I have verified that that issue exists against the master branch of Django REST framework.
  • I have searched for similar issues in both open and closed tickets and cannot find a duplicate.
  • This is not a usage question. (Those should be directed to the discussion group instead.)
  • This cannot be dealt with as a third party library. (We prefer new functionality to be in the form of third party libraries where possible.)
  • I have reduced the issue to the simplest possible case.
  • I have included a failing test as a pull request. (If you are unable to do so we can still accept the issue.)

Steps to reproduce

I added live api docs but instead of rendering as html it renders as text

Expected behavior

image

Actual behavior

It should render forms

@tomchristie
Copy link
Member

tomchristie commented Mar 9, 2017

How do you reproduce this?
Is anyone else seeing the same behavior?
Somewhat odd that I've never see this kind of thing when working on the functionality.

@atkawa7
Copy link
Contributor Author

atkawa7 commented Mar 9, 2017

@tomchristie I have created a PR to fix the error I was having by turning auto escaping off on the following line and this

@atkawa7
Copy link
Contributor Author

atkawa7 commented Mar 9, 2017

@toXel
Copy link

toXel commented Mar 9, 2017

Yea I have the same behavior. And yes the PR from @atkawa7 fixes it for me.

@tomchristie tomchristie added this to the 3.6.2 Release milestone Mar 10, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

3 participants