Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Updated `package.json` deps to latest UglifyJS. #170

Closed
wants to merge 2 commits into from

3 participants

@cristiantincu

UglifyJS < 1.3.2 produces broken minified code that affects Ender builds.
UglifyJS ≥ 1.3.2 solves this issue.

@ded
Owner

we probably should have just put it exactly to 1.3.0.

for something like this, i think it's probably safer for us to set a hard number, rather than using the >= operator. then update it in the future when we feel uglify is worth upgrading (and stable).

mind changing it to just say "uglify-js": "1.3.4"

@cristiantincu

Thank you, @ded.

Edit:
FWIW, mishoo is working for some time on UglifyJS2, which is already at 2.2.1 and this new thing is even more awesome (more efficient, source map support, etc).

@amccollum
Owner

I'm happy to report that ender@2.0.x now uses UglifyJS2.

@amccollum amccollum closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  package.json
View
2  package.json
@@ -15,7 +15,7 @@
, "dependencies": {
"npm": ">= 1.1.26"
, "colors": ">= 0.6.0"
- , "uglify-js": ">= 1.3.0"
+ , "uglify-js": "1.3.4"
, "async": ">= 0.1.22"
}
, "devDependencies": {
Something went wrong with that request. Please try again.