Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

undefined method `middleware' #3

Open
o-sam-o opened this Issue · 2 comments

2 participants

@o-sam-o

ska:swarm sam$ rails g rails_metrics Metric
DEPRECATION WARNING: railtie_name is deprecated and has no effect. (called from at /Users/sam/Programming/ruby/swarm/config/application.rb:7)
/Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/railties-3.0.0/lib/rails/railtie/configuration.rb:76:in method_missing': undefined methodmiddleware' for #Rails::Engine::Configuration:0x000001015dd958 (NoMethodError)
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/rails_metrics-0.1/lib/rails_metrics/engine.rb:6:in <class:Engine>'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/rails_metrics-0.1/lib/rails_metrics/engine.rb:2:in
module:RailsMetrics'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/rails_metrics-0.1/lib/rails_metrics/engine.rb:1:in <top (required)>'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/rails_metrics-0.1/lib/rails_metrics.rb:112:in
require'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/rails_metrics-0.1/lib/rails_metrics.rb:112:in <top (required)>'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler/runtime.rb:64:in
require'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler/runtime.rb:64:in block (2 levels) in require'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler/runtime.rb:62:in
each'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler/runtime.rb:62:in block in require'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler/runtime.rb:51:in
each'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler/runtime.rb:51:in require'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/bundler-1.0.0.rc.6/lib/bundler.rb:112:in
require'
from /Users/sam/Programming/ruby/swarm/config/application.rb:7:in <top (required)>'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/railties-3.0.0/lib/rails/commands.rb:15:in
require'
from /Users/sam/.rvm/gems/ruby-1.9.2-p0@sw/gems/railties-3.0.0/lib/rails/commands.rb:15:in <top (required)>'
from script/rails:6:in
require'

@splattael

It works in master and has been fixed in: 552e811

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.