Skip to content
Browse files

update rails for security patch and add travis support

  • Loading branch information...
1 parent 6f184ff commit 595f7416ae12d8598da64f45be4a4bf3b3e711f5 @mkb mkb committed Feb 11, 2013
Showing with 49 additions and 36 deletions.
  1. +0 −2 .bundle/config
  2. +13 −0 .travis.yml
  3. +1 −1 Gemfile
  4. +33 −33 Gemfile.lock
  5. +2 −0 Rakefile
View
2 .bundle/config
@@ -1,2 +0,0 @@
---- {}
-
View
13 .travis.yml
@@ -0,0 +1,13 @@
+language: ruby
+rvm:
+ - 1.8.7
+ - 1.9.2
+ - 1.9.3
+ - 2.0.0
+ - jruby-18mode
+ - jruby-19mode
+ - rbx-18mode
+ - rbx-19mode
+script: bundle exec rake travis
+
+
View
2 Gemfile
@@ -1,6 +1,6 @@
source 'http://rubygems.org'
-gem "rails", "~> 3.2.11"
+gem "rails", "~> 3.2.12"
gem 'simple_form'
gem 'jquery-rails'
View
66 Gemfile.lock
@@ -1,31 +1,31 @@
GEM
remote: http://rubygems.org/
specs:
- actionmailer (3.2.11)
- actionpack (= 3.2.11)
+ actionmailer (3.2.12)
+ actionpack (= 3.2.12)
mail (~> 2.4.4)
- actionpack (3.2.11)
- activemodel (= 3.2.11)
- activesupport (= 3.2.11)
+ actionpack (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
builder (~> 3.0.0)
erubis (~> 2.7.0)
journey (~> 1.0.4)
- rack (~> 1.4.0)
+ rack (~> 1.4.5)
rack-cache (~> 1.2)
rack-test (~> 0.6.1)
sprockets (~> 2.2.1)
- activemodel (3.2.11)
- activesupport (= 3.2.11)
+ activemodel (3.2.12)
+ activesupport (= 3.2.12)
builder (~> 3.0.0)
- activerecord (3.2.11)
- activemodel (= 3.2.11)
- activesupport (= 3.2.11)
+ activerecord (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
arel (~> 3.0.2)
tzinfo (~> 0.3.29)
- activeresource (3.2.11)
- activemodel (= 3.2.11)
- activesupport (= 3.2.11)
- activesupport (3.2.11)
+ activeresource (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ activesupport (3.2.12)
i18n (~> 0.6)
multi_json (~> 1.0)
arel (3.0.2)
@@ -47,46 +47,46 @@ GEM
jquery-rails (2.1.2)
railties (>= 3.1.0, < 5.0)
thor (~> 0.14)
- json (1.7.6)
+ json (1.7.7)
kgio (2.7.4)
mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.19)
- multi_json (1.5.0)
+ mime-types (1.21)
+ multi_json (1.5.1)
mysql2 (0.3.11)
pg (0.14.1)
polyglot (0.3.3)
puma (1.6.3)
rack (~> 1.2)
- rack (1.4.3)
+ rack (1.4.5)
rack-cache (1.2)
rack (>= 0.4)
- rack-ssl (1.3.2)
+ rack-ssl (1.3.3)
rack
rack-test (0.6.2)
rack (>= 1.0)
- rails (3.2.11)
- actionmailer (= 3.2.11)
- actionpack (= 3.2.11)
- activerecord (= 3.2.11)
- activeresource (= 3.2.11)
- activesupport (= 3.2.11)
+ rails (3.2.12)
+ actionmailer (= 3.2.12)
+ actionpack (= 3.2.12)
+ activerecord (= 3.2.12)
+ activeresource (= 3.2.12)
+ activesupport (= 3.2.12)
bundler (~> 1.0)
- railties (= 3.2.11)
+ railties (= 3.2.12)
rails_autolink (1.0.9)
rails (~> 3.1)
- railties (3.2.11)
- actionpack (= 3.2.11)
- activesupport (= 3.2.11)
+ railties (3.2.12)
+ actionpack (= 3.2.12)
+ activesupport (= 3.2.12)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (>= 0.14.6, < 2.0)
raindrops (0.10.0)
rake (10.0.3)
- rdoc (3.12)
+ rdoc (3.12.1)
json (~> 1.4)
sass (3.2.1)
sass-rails (3.2.5)
@@ -102,7 +102,7 @@ GEM
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
sqlite3 (1.3.6)
- thor (0.16.0)
+ thor (0.17.0)
tilt (1.3.3)
treetop (1.4.12)
polyglot
@@ -132,7 +132,7 @@ DEPENDENCIES
mysql2
pg
puma
- rails (~> 3.2.11)
+ rails (~> 3.2.12)
rails_autolink
sass-rails
simple_form
View
2 Rakefile
@@ -5,3 +5,5 @@ require File.expand_path('../config/application', __FILE__)
require 'rake'
Listr::Application.load_tasks
+
+task :travis => ['db:create:all', 'db:migrate', :default]

0 comments on commit 595f741

Please sign in to comment.
Something went wrong with that request. Please try again.