A package for compatibility from Inquirer.
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
lib
.editorconfig
.eslintrc.yml
.gitignore
.npmrc
.travis.yml
LICENSE
README.md
package.json

README.md

enquirer-compat

This package helps you switch from Inquirer to Enquirer without heavy code changes.

Usage

Install it:

npm i enquirer-compat

Change your code like this:

- const inquirer = require('inquirer')
+ const inquirer = require('enquirer-compat')

Don't forget to test your code after that.

Known Issues

Not all features of Inquirer are supported or implemented in Enquirer.

  • NOT supports rawlist, expand, editor prompts.
  • NOT supports separator.

License

MIT License (c) 2018-present Pig Fang