Commits on Jun 7, 2016
  1. @tanzoniteblack
  2. @tanzoniteblack
  3. @tanzoniteblack

    Release 0.0.5

    tanzoniteblack committed Jun 7, 2016
  4. @fommil

    Merge pull request #30 from rreckel/master

    Add support for javadocs
    fommil committed Jun 7, 2016
  5. @rreckel

    Add support for javadocs

    rreckel committed Jun 7, 2016
Commits on Jun 3, 2016
  1. @tanzoniteblack

    Merge pull request #29 from rreckel/new_formatter_prefs

    Formatter prefs use new options from scalariform
    tanzoniteblack committed Jun 3, 2016
  2. @rreckel
Commits on Mar 25, 2016
  1. @tanzoniteblack

    Initialize 0.0.5-SNAPSHOT

    tanzoniteblack committed Mar 25, 2016
  2. @tanzoniteblack

    Release 0.0.4 to sonatype

    tanzoniteblack committed Mar 25, 2016
  3. @fommil

    Merge pull request #28 from gruggiero/target-fix

    Changed target and test-target in .ensime to targets and test-targets
    fommil committed Mar 25, 2016
  4. @gruggiero
Commits on Feb 12, 2016
  1. @fommil

    Merge pull request #23 from kpadmasola/master

    Fix for #21
    fommil committed Feb 12, 2016
  2. @kpadmasola

    Fix for #21

    + check for JDK/lib/tools.jar when verifying if JDK is installed.
    + replace backslashes in Windows paths with forward slashes.
    kpadmasola committed Feb 12, 2016
Commits on Feb 11, 2016
  1. @tanzoniteblack

    Merge pull request #24 from parsnips/fixup-drone-build

    follow the ensime-sbt way of calling publish
    tanzoniteblack committed Feb 11, 2016
  2. @parsnips
Commits on Feb 3, 2016
  1. @fommil

    Merge pull request #22 from tanzoniteblack/ignore-pom-artifacts

    Ignore pom artifact types
    fommil committed Feb 3, 2016
Commits on Feb 2, 2016
  1. @tanzoniteblack

    Ignore pom artifact types

    One of my projects has a dependency that looks like:
    
    ```xml
    <dependency>
    	<groupId>com.github.fommil.netlib</groupId>
    	<artifactId>all</artifactId>
    	<version>1.1.2</version>
    	<type>pom</type>
    </dependency>
    ```
    
    This ends up going into the `.ensime` file along with all the dependency
    jars, and then causes ensime to throw an error because it's not a zip
    file. So let's just avoid putting anything into the the source roots
    unless it's a jar type file according to the artifact data.
    tanzoniteblack committed Feb 2, 2016
Commits on Jan 17, 2016
  1. @fommil

    apache license

    this is alluded to in some headers, lets make it formal for the project.
    fommil committed Jan 17, 2016
Commits on Jan 16, 2016
  1. @parsnips

    Merge pull request #19 from tanzoniteblack/docs

    Add installation and usage notes to readme
    parsnips committed Jan 16, 2016
  2. @tanzoniteblack
Commits on Jan 14, 2016
  1. @tanzoniteblack

    Merge pull request #17 from tanzoniteblack/0.0.4-SNAPSHOT

    Update version to 0.0.4-SNAPSHOT
    tanzoniteblack committed Jan 14, 2016
  2. @tanzoniteblack

    Update version to 0.0.4-SNAPSHOT

    0.0.3 has now been released to sonatype
    tanzoniteblack committed Jan 14, 2016
  3. @parsnips
  4. @parsnips

    correct the target

    parsnips committed Jan 14, 2016
  5. @parsnips

    Merge pull request #16 from tanzoniteblack/sonatype-deploy

    Update distribution management
    parsnips committed Jan 14, 2016
  6. @tanzoniteblack

    Update distribution management

    Update the distributionManagement to be able to deploy changes to
    sonatype's repositories.
    tanzoniteblack committed Jan 13, 2016
Commits on Jan 9, 2016
  1. @parsnips

    Merge pull request #15 from tanzoniteblack/scalariform

    Configure scalariform to run automatically
    parsnips committed Jan 8, 2016
Commits on Jan 8, 2016
  1. @tanzoniteblack

    Configure scalariform to run automatically

    In my last PR (#13), I
    mentioned that we should actually run scalariform on this project. So,
    here that is. The config is taken from
    https://github.com/tanzoniteblack/ensime-maven/blob/scalariform/src/ensime/formatter.properties
    , but I actually have no strong preferences one way or the other on any
    of these values.
    
    Note: The way that I set up the pom.xml, it will run scalariform
    automatically when you compile the code.
    tanzoniteblack committed Jan 8, 2016
Commits on Jan 6, 2016
  1. @parsnips

    Merge pull request #10 from parsnips/drone

    first stab at a drone
    parsnips committed Jan 6, 2016
  2. @parsnips @parsnips

    ensimify

    - drone
    - ensime namespaces
    parsnips committed with parsnips Dec 21, 2015
  3. @parsnips

    Merge pull request #13 from tanzoniteblack/sexpr-int

    Add support for int output to `.ensime` files
    parsnips committed Jan 6, 2016
  4. @parsnips

    Merge pull request #12 from tanzoniteblack/default-scala

    Update default scala version
    parsnips committed Jan 6, 2016
Commits on Dec 30, 2015
  1. @tanzoniteblack

    Re-enable maxArrowIndent formatting preference

    This works fine now that ensime supports periods in
    names (ensime/ensime-server#874) and that
    we've fixed ints being printed into the `.ensime` file as a string.
    tanzoniteblack committed Dec 30, 2015
  2. @tanzoniteblack

    Add support for int output to `.ensime` files

    Certain items in :formatting-prefs are supposed to be integers, not
    strings, so add support for these.
    
    Specific item that was causing issues for me was `indentSpaces` in this
    project itself, which would print as `:indentSpaces "2"`, which unless I
    deleted that particular line would prevent ensime from starting up to
    hack around on this project. With this change, it now goes into the
    `.ensime` file as `:indentSpaces 2`.
    tanzoniteblack committed Dec 30, 2015
  3. @tanzoniteblack

    Update default scala version

    If we attempt to run ensime with the current default version of 2.9.2,
    we get the following dependency errors:
    
    ```
    [warn] 	::::::::::::::::::::::::::::::::::::::::::::::
    [warn] 	::          UNRESOLVED DEPENDENCIES         ::
    [warn] 	::::::::::::::::::::::::::::::::::::::::::::::
    [warn] 	:: com.typesafe.akka#akka-actor;2.0.5: not found
    [warn] 	:: com.typesafe.akka#akka-slf4j;2.0.5: not found
    [warn] 	::::::::::::::::::::::::::::::::::::::::::::::
    
    ```
    
    Updating to to 2.10.6 fixes this issue.
    
    If you're wondering how I got into this mess, it's because I've started
    to use ensime to replace eclim for working with Java in Emacs on my
    maven projects, which don't have a scala dependency of their own.
    tanzoniteblack committed Dec 30, 2015